Recipes should not have user-entered sourcepackage

Bug #581898 reported by Aaron Bentley on 2010-05-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Medium
Paul Hummer

Bug Description

The sourcepackage that a recipe will generate should not be user-entered, because it is not a prerequisite for building. Users find it surprising. Instead, we should use the sourcepackage from the latest successful build.

We may choose to simply delete the database column, or we can use it as a cache.

Paul Hummer (rockstar) on 2010-06-10
Changed in launchpad-code:
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
assignee: nobody → Paul Hummer (rockstar)
milestone: none → 10.05
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers