Horizontal cursor do new translation

Bug #570899 reported by Martin Lukeš on 2010-04-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Adi Roiban

Bug Description

When I click on suggested translation, then click to text field to move cursor as I read original string (or whatever reason), horizontal movement (left and right cursor keys) in text field will mark suggested translation as New translation. Even though I did not made any changes.
There is a risk that I overlook it, hit Save & Continue and translation I intended to only approve is hereby translated and reviewed by me. This isn't fair to original translator regarding Karma and morally.

Related branches

I've confirmed it in Firefox. It doesn't happen in either Epiphany (webkit) or Chromium.

Changed in rosetta:
status: New → Triaged
importance: Undecided → High
Adi Roiban (adiroiban) wrote :

I guess this is my fault. I will try to fix it.

Changed in rosetta:
assignee: nobody → Adi Roiban (adiroiban)
Changed in rosetta:
status: Triaged → In Progress
Changed in rosetta:
milestone: none → 10.05
status: In Progress → Fix Committed
tags: added: qa-needstesting
Adi Roiban (adiroiban) on 2010-05-25
tags: added: qa-ok
removed: qa-needstesting
Curtis Hovey (sinzui) on 2010-06-02
Changed in rosetta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers