Users shouldn't be able to change or register blacklisted names.

Bug #56669 reported by Joey Stanford
4
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
Medium
Stuart Bishop

Bug Description

Joey registered the name '1' in Launchpad but that name is blacklisted. When he signed the CoC and became member of the ubuntumembers team he expected to have an <email address hidden> email address registered but that never happened.

What should have happened:
He should have received a message telling him that '1' is not a valid name at the moment he tried to register/change it.

https://features.launchpad.net/products/launchpad/+spec/name-blacklist

Joey Stanford (joey)
description: updated
Revision history for this message
Joey Stanford (joey) wrote :

details:

<email address hidden>: host fiordland.ubuntu.com[82.211.81.145] said: 550
    <email address hidden>: Recipient address rejected: User unknown in virtual alias
    table (in reply to RCPT TO command)

Revision history for this message
Brandon Holtsclaw (imbrandon) wrote :

afaik @ubuntu.com email address are NOT auto synced to the alias file, you need to request it ( i guess this can be considered a request ) after you have become a ubuntu member ( and you have ) but not with signing the CoC thats is just becoming an ubuntuero ;)

If there is a problem with the alias they will notify you when it go's to be synced.

Revision history for this message
Diogo Matsubara (matsubara) wrote :

Hi Joey,

'<email address hidden>' is indeed a blacklisted name. I confirmed that with one of the admins today.
To solve that and activate a @ubuntu.com email address you would need to change your Launchpad name.

Thanks for reporting.

description: updated
Changed in launchpad:
importance: Untriaged → Medium
status: Unconfirmed → Confirmed
Revision history for this message
Joey Stanford (joey) wrote :

in addition I've tried 911 and jjs (which is my current person.$name now) and the email forward just doesn't work. Mildly annoying since I'm waiting on this to work so I can print business cards. (I run the Colorado LOCO team and have already ran out of my personal generic linux cards.) I'm beginning to wonder if something else is awry...a cron job perhaps that isn't running. Although, everyone who made member with me has an address so it appears that it's just my account.

Revision history for this message
Diogo Matsubara (matsubara) wrote :

Hi Joey,

your email should be working by now. The list of emails must be manually approved and that caused the delay.
Sorry about that and thanks for reporting.

Revision history for this message
Joey Stanford (joey) wrote :

Working great as <email address hidden> thanks!

Revision history for this message
Stuart Bishop (stub) wrote :

Launchpad now has a blacklist stored in the database and attempting to set a name to a blacklisted value gives the user a 'name is has been blacklisted' error message.

Changed in launchpad:
assignee: nobody → stub
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related blueprints