+changelog includes misleading information related to package versions and authors

Bug #55795 reported by Bart Martens on 2006-08-09
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

The changelog at

https://launchpad.net/distros/ubuntu/edgy/+source/discover/+changelog

disagrees with the changelog at:

http://packages.debian.org/changelogs/pool/main/d/discover/current/changelog

crediting Gauvain for a set of changes that Bart did. The reason this happens is because:

a) This package discover=2.0.7-3 was manually synced into Ubuntu as discover=2.0.7-3ubuntu1
b) The changes file includes information for both versions. The changes file doesn't credit the original author, mainly because the format is hard to change, according to James.
c) We use the information from the changes file to generate the information displayed on +changelog.

The stated Ubuntu policy is to include all modification changelogs in the changes file, which means that we will need to find another way of generating the +changelog data to avoid the problem with missing/wrong credit.

It is likely that the best way to do this is to store the debian/changelog file in the librarian, and to use that when displaying the +changelog.

We could as a first step just link to the librarian file. For bonus points, we could read() the librarian content and then linkify it. Note that linkification should only be done for packages which we know about -- we could do that by grabbing all valid package versions and then only linking versions we knew about.

Bart Martens (bartm) wrote :

But, as Gauvain correctly noted, the real changelog is:

discover (2.0.7-3ubuntu1) edgy; urgency=low

  * Merge from debian unstable:
     - discover.dtd: Change device->model default to 'default'
     - Miscellaneous changes to allow default entries for vendors

 -- Gauvain Pocentek <email address hidden> Mon, 31 Jul 2006 01:44:51 +0100

discover (2.0.7-3) unstable; urgency=low

  * QA upload.
  * NMU ACK. Closes: #305042. Thanks to Jeroen and David, see below.
  * sysdeps/stub/stubs.c: Fix FTBFS on GNU/kFreeBSD (and any system using
    sysdep/stubs/). Closes: #364863. Patch by Robert Millan
    <email address hidden>, thanks.
  * doc/discover-modprobe.8, debian/discover.postrm: Removed "/usr/local" from
    paths in man page, and added removal of /var/lib/discover in postrm.
    Closes: #328497. Thanks to Lars Wirzenius <email address hidden>.
  * debian/discover.postinst: Enter invoke-rc.d. Closes: #367739.
  * doc/device-types.xml, doc/discover.1, doc/guide.html, doc/guide.txt: Fixed
    typo. Closes: #311442.
  * debian/rules: Fixed debian-rules-missing-required-target binary-indep.
  * debian/changelog: Fixed syntax-error-in-debian-changelog.

 -- Bart Martens <email address hidden> Sat, 29 Jul 2006 12:36:08 +0200

discover (2.0.7-2.1ubuntu1) dapper; urgency=low

  * Resynchronise with Debian.

 -- Martin Meredith <email address hidden> Wed, 2 Nov 2005 21:10:47 +0000

So my request is to display the debian/changelog in launchpad without replacing the Debian maintainer by the Ubuntu maintainer.

Thanks,

Bart Martens
<email address hidden>

Christian Reis (kiko) on 2006-08-10
description: updated
Celso Providelo (cprov) on 2006-08-10
Changed in launchpad:
importance: Untriaged → Medium
status: Unconfirmed → Confirmed
Bart Martens (bartm) wrote :

I don't know how to change the title back to what I originally posted, so I mark this bug as rejected and post a new one.

Changed in soyuz:
status: Confirmed → Rejected
James Henstridge (jamesh) wrote :

You can change the bug title with the "Description & Tags" link in the top right (this is not as obvious as it could be).

Changed in soyuz:
status: Rejected → Confirmed
James Henstridge (jamesh) wrote :

Bart: the changelog displayed in Launchpad is actually constructed from the .changes file for the package (by combining the "Changes", "Changed-By" and "Date" values).

It isn't a case of reading the debian/changelog file and then mangling it.

Wouter van Heyst (larstiq) wrote :

On storing the debian/changelog file in the librarian, how would that be done? Assuming each new upload only tacks on new entries and thus only storing the diff has some potential problems. As far as I know, it is possible to have the entry of a specific version change between uploads (fixing a typo in a bug number for example), though frowned upon.

Another case is where there are two lines of development on a package, and one supercedes the other. One uploaded to experimental and when it is time to upload to unstable the other branch is chosen.

I'll have to dig up some solid evidence on this, but my mind seems to think having seen this happen in Debian.

Wouter van Heyst (larstiq) wrote :

A good example would be: http://packages.qa.debian.org/d/dpkg/news/20070102T101703Z.html

* Fix year 2018 in changelog for Michael Alan Dorman's upload in 1998,
     which was confusing the changelog parsers. Closes: #402526

Emilio Pozuelo Monfort (pochu) wrote :

Quoting James Henstridge:
> Bart: the changelog displayed in Launchpad is actually constructed
> from the .changes file for the package (by combining the "Changes",
> "Changed-By" and "Date" values).

That's precisely the problem when syncing packages, since syncs have in Changed-By the person who requested the sync, and not the person who did the changes.

For example, I've been requesting syncs for gdl, and I'm listed as the author of 0.7.10-1, where it was Rob Bradford who did it (and has done for almost all the uploads listed in that page, but he's only credited in one).

Emilio Pozuelo Monfort (pochu) wrote :

>For example, I've been requesting syncs for gdl, and I'm
> listed as the author of 0.7.10-1, where it was Rob Bradford
> who did it (and has done for almost all the uploads listed
> in that page, but he's only credited in one).

Forgot the url:
https://edge.launchpad.net/ubuntu/+source/gdl

Changed in soyuz:
milestone: none → pending
Robert Collins (lifeless) wrote :

Not currently scheduled - putting into the pool of backlogged items. A patch would be wonderful if someone wants to address this.

Changed in launchpad:
importance: Medium → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers