Upstream Status search options are confusing and poorly presented

Bug #55555 reported by Brad Bollenbach on 2006-08-07
4
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Brad Bollenbach

Bug Description

https://launchpad.net/distros/ubuntu/+bugs?advanced=1

has four options for Upstream Status:

() Doesn't matter
() Show only bugs that need to be linked to an upstream bug report
() Hide bugs that are open upstream
() Show only bugs that are closed upstream

There are some problems with this UI, as kiko pointed out to me:

1. "Doesn't matter" should be selected by default. Right now, no option is selected by default.

2. The third and fourth options take considerable thought to understand.

3. Show/Hide/Show == bad. Show/Show/Show or Hide/Hide/Hide == better.

4. They don't work the way kiko expected when he read the options. (More on that later.)

Brad Bollenbach (bradb) on 2006-08-07
Changed in malone:
importance: Untriaged → High
status: Unconfirmed → Confirmed
Christian Reis (kiko) wrote :

I think 4. has to do with what the options seem to advertise. For instance:

 * Hide bugs that are open upstream
 * Show only bugs that are closed upstream

The behaviour for the third option is mysterious for bugs which have no upstream bug report linked.

(To be honest, what's the semantic difference between the third and fourth options?)

The behaviour for the fourth option seems to be just wrong. Issue the query:

https://launchpad.net/distros/ubuntu/+bugs?field.searchtext=&orderby=-importance&field.status%3Alist=Unconfirmed&field.status%3Alist=Needs+Info&field.status%3Alist=Confirmed&field.status%3Alist=In+Progress&field.status%3Alist=Fix+Committed&assignee_option=any&field.assignee=&field.owner=&field.component-empty-marker=1&field.status_upstream=only_closed&field.status_upstream-empty-marker=1&field.omit_dupes.used=&field.omit_dupes=on&field.has_patch.used=&field.has_no_package.used=&search=Search

and inspect some of the bugs in the results:

https://launchpad.net/distros/ubuntu/+source/sketch/+bug/5347
https://launchpad.net/distros/ubuntu/+source/krb4/+bug/27948
https://launchpad.net/distros/ubuntu/+source/convertfs/+bug/31401
https://launchpad.net/distros/ubuntu/+source/xorg-server/+bug/36461
https://launchpad.net/distros/ubuntu/+source/scim/+bug/42024

not one of those has an upstream bug task associated with it. So I'm not sure why they are being returned.

Brad Bollenbach (bradb) on 2006-08-08
Changed in malone:
assignee: nobody → bradb
status: Confirmed → In Progress
Brad Bollenbach (bradb) on 2006-08-11
Changed in malone:
status: In Progress → Fix Committed
Brad Bollenbach (bradb) wrote :

Reopening because the "closed upstream" report is not very sane.

Changed in malone:
status: Fix Committed → In Progress
Christian Reis (kiko) wrote :

Fixed in production a while back.

Changed in malone:
status: In Progress → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/55555

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers