publisher gets very unhappy about unknown distroreleases

Bug #55288 reported by Colin Watson
4
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
High
Jelmer Vernooij

Bug Description

Following the mistaken creation of dapper.0 and before we found somebody with DELETE privileges to get rid of it, the publisher crashed every time as follows:

10:07:57 DEBUG Finding distribution and distrorelease objects.
10:07:57 DEBUG Finding configuration.
10:07:57 ERROR No Lucille configuration section for dapper.0

It would be really good if "never heard of this distrorelease" were handled by skipping that distrorelease rather than crashing.

Related branches

James Troup (elmo)
Changed in soyuz:
importance: Untriaged → High
status: Unconfirmed → Confirmed
Revision history for this message
Christian Reis (kiko) wrote :

Doing this is actually not as easy as it sounds. The reason is that the publisher assumes in many places that /all/ releases it is considering have lucille configs set up; we'd need to refactor some code to actually be able to do this. At any rate while this is bad it is also going to bite us only very rarely.

Changed in soyuz:
importance: High → Medium
Celso Providelo (cprov)
Changed in soyuz:
assignee: nobody → cprov
importance: Medium → High
milestone: none → pending
status: Confirmed → Triaged
Revision history for this message
Joey Stanford (joey) wrote :

Bit OEM today when Jaunty was created and the publishers stopped.

Revision history for this message
Celso Providelo (cprov) wrote :

As mentioned in bug #291344, this is another symptom of a wider problem in a way out code expects new distroseries to be created and immeditely initialized.

In the context of this bug, I think we should get rid of 'lucilleconfig' and use ComponentSelection. First, because python-config text format in DB is gross, and then, from the design PoV, CS will better coupled (dynamically adjustable) with the publishing system.

Curtis Hovey (sinzui)
Changed in soyuz:
assignee: Celso Providelo (cprov) → nobody
tags: added: soyuz-publisher
tags: added: oops
Jelmer Vernooij (jelmer)
Changed in soyuz:
assignee: nobody → Jelmer Vernooij (jelmer)
Jelmer Vernooij (jelmer)
Changed in soyuz:
status: Triaged → In Progress
Revision history for this message
Launchpad QA Bot (lpqabot) wrote : Bug fixed by a commit
tags: added: qa-needstesting
Ursula Junque (ursinha)
Changed in soyuz:
status: In Progress → Fix Committed
milestone: pending → 10.09
Jelmer Vernooij (jelmer)
tags: added: qa-ok
removed: qa-needstesting
Curtis Hovey (sinzui)
Changed in soyuz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers