Please change "Origin" and "Label" in the Release file on archive.canonical.com

Bug #552560 reported by Michael Vogt on 2010-03-31
26
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Steve Kowalik
software-center (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

Software-center is now using the information from the Release file [1] and displays it in the UI. It would be great if something like:
Origin: Canonical
Label: Partner archive

could be used (currently it uses Ubuntu, Ubuntu).

[1] http://archive.canonical.com/dists/lucid/Release

Related branches

Michael Vogt (mvo) wrote :

Adding a software-center task, this is currently responsible for making the detection of new repositories fail when "partner" got added. Because of the same origin it will fail to detect the new channel and fail to index it.

Changed in software-center (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
milestone: none → ubuntu-10.04
Julian Edwards (julian-edwards) wrote :

Steve, this is pretty easy to fix, there's already some code in the publisher that futzes about with the Origin etc.

Changed in soyuz:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Steve Kowalik (stevenk)
milestone: none → 10.04
Philip Muškovac (yofel) on 2010-04-14
Changed in software-center (Ubuntu Lucid):
status: Confirmed → Triaged
Matthew Paul Thomas (mpt) wrote :

Michael, where are you suggesting that "Canonical" and "Partner archive" would be shown in the interface?

Michael Vogt (mvo) wrote :

Matthew, I'm not suggesting that at all. But I need a different Origin/Label than the ubuntu main archive is using.

description: updated
Michael Vogt (mvo) wrote :

This is most likely the cause for e.g. bug #564768

Colin Watson (cjwatson) wrote :

Bumping to lucid-updates, as it doesn't look as though the Soyuz change will be available in time to get a matching software-center fix prepared and tested for 10.04 final. It shouldn't hurt to do this in an SRU instead once Soyuz has been changed, and we can change partner's Release file post-release with little trouble.

Changed in software-center (Ubuntu Lucid):
milestone: ubuntu-10.04 → lucid-updates
Changed in soyuz:
milestone: 10.04 → 10.05
Changed in soyuz:
milestone: 10.05 → 10.06
Changed in soyuz:
status: Triaged → Fix Committed
tags: added: qa-needstesting
Steve Kowalik (stevenk) wrote :

This has been QA'd on dogfood by uploading a new package to partner, and then running the publisher for partner repo.

tags: added: qa-ok
removed: qa-needstesting
Curtis Hovey (sinzui) on 2010-07-07
Changed in soyuz:
status: Fix Committed → Fix Released
Changed in software-center (Ubuntu):
status: Triaged → Fix Committed
Changed in software-center (Ubuntu Lucid):
status: Triaged → Fix Committed
Matthew Paul Thomas (mpt) wrote :

I think this may have caused bug 604693.

Gary Lasker (gary-lasker) wrote :

Hello stevenk! The fix is definitely what we need for Software Center. Now that we have it, we can pull the (now errant) special case code that was used for detecting the the partner channel, so it did indeed make it simpler and more correct. As mpt points out, however, that special case code caused a bug in Software Center once the the Soyuz fix was deployed for lucid (see bug 604693).

mvo has made a fix for this, but I noticed that the fix does not work under maverick. The reason is that it appears that the release file hasn't been updated for maverick yet:

  http://archive.canonical.com/dists/maverick/Release

"Origin: Ubuntu
 Label: Ubuntu
 Suite: maverick
 Version: 10.10
 ..."

Can we do an upload to the partner repo in maverick, maybe a no-change rebuild or somesuch, and then rerun the publisher?
Or update it some other way?

Thanks!

If you ask Brian Thomason, he might be able to do that upload for you.

Cheers.

Gary Lasker (gary-lasker) wrote :

Thanks Julian, I checked with Brian and he's got an upload that will be ready to go in the next day or so.

Accepted software-center into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 2.1.5

---------------
software-center (2.1.5) maverick; urgency=low

  [ Michael Vogt ]
  * softwarecenter/backend/aptd.py:
    - fix in channel adding code
  * merged lp:~mvo/software-center/lazr to support gobject
    based wrapper around lazr.restfulclient apps
  * merged lp:~mmcg069/software-center/pathbar-tweaks,
    many thanks
  * merged lp:~mvo/software-center/appdetails-in-db that
    improve the AppDetails abstraction
  * merged lp:~mvo/software-center/plugin-support (important
    for the oneconf integration)
  * merged lp:~osomon/software-center/close_in_progress
    that fixes LP:#431907, thanks to Olivier Tilloy
  * remove specal cases for partner now that soyuz
    LP: #552560 is fixed (LP: #604693)
  * software-center:
    - fixes in the logging code (thanks to Geliy Sokolov)
  * merged lp:~and471/software-center/dialog-work that improves
    the dialogs (many thanks!)

  [ Gary Lasker ]
  * data/icons/scalable/apps/category-show-all.svg,
    data/icons_unbranded/scalable/apps/category-show-all.svg,
    softwarecenter/view/catview_gtk.py:
    - add custom icon for single-pane dept view "All" button;
      icon created by Dani Planas Armangue, many thanks!
      (LP: #599644)
  * softwarecenter/view/pkgview.py:
    - replace svg icon with png version because the svg version
      has been removed from gnome-icon-theme (LP: #601987)
  * po/POTFILES.in:
    - update to latest set of modules
  * merge lp:~mmcg069/software-center/appdetailsview-gtk, adds
    Matthew McGowan's new gtk-based appdetailsview, many thanks!
    Thanks also to kiwinote and mvo for refactoring for new
    AppDetails class and other changes. Also fixes LP: #578650.
  * softwarecenter/apt/aptcache.py:
    - tweak timeout value when opening the apt cache
      (LP: #602610)
  * merge lp:~mmcg069/software-center/appdetailsview-gtk, fixes
    description parsing error for e.g. The Gimp. Many thanks!
  * softwarecenter/app.py,
    softwarecenter/view/availablepane.py,
    softwarecenter/view/navhistory.py:
    - navigation history fixes
  * data/ui/dialogs.ui,
    softwarecenter/app.py,
    softwarecenter/enums.py,
    softwarecenter/view/appdetailsview.py,
    softwarecenter/view/appdetailsview_gtk.py,
    softwarecenter/view/appdetailsview_webkit.py,
    softwarecenter/view/appview.py,
    softwarecenter/view/softwarepane.py:
    - consolidate install/remove action handling to
      one place, now shows dep package removal dialog
      for all cases; fix response ids for dialogs
 -- Michael Vogt <email address hidden> Fri, 16 Jul 2010 09:14:22 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in software-center (Ubuntu Lucid):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers