shouldn't require careful publisher run when cloning new released distrorelease

Bug #55211 reported by Colin Watson on 2006-08-04
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Medium
Jeroen T. Vermeulen

Bug Description

<Kinnison> cprov: why do you think you need to careful?
<Kinnison> cprov: you prepare dapper.0, and set it FROZEN, then a normal run will apt-ftparchive it
<Kinnison> cprov: then you mark it released and compare
<cprov> Kinnison: uhm, the FROZEN trick must do, good point
<Kamion> ah
<Kamion> seems like a bug - if it doesn't exist, it should be apt-ftparchived no matter what state it's in, surely
<Kamion> well, possibly except for obsolete
<cprov> Kamion: currently the part that creates inexistent directoris in archive is not smart enough to transmit such situation to the a-f runner ... we could do it. File a bug on soyuz, please

(We ran into this when attempting to create dapper.0 from dapper prior to a point release. It wouldn't be a problem when creating normal non-released distroreleases.)

Related branches

Celso Providelo (cprov) wrote :

It will be addressed after ArchiveRework tasks, by adding restricted arguments only to the publishing API.
IMO, it's not really required by now, since we have a simpler manner to ship DotReleases.

Changed in soyuz:
importance: Untriaged → Medium
status: Unconfirmed → Confirmed
Colin Watson (cjwatson) on 2010-10-11
tags: added: new-release-cycle-process
Colin Watson (cjwatson) wrote :

To amend my original description slightly: we also need a careful publisher run when creating new non-released distroseries, as otherwise we don't get indices for -proposed, -updates, -security, and -backports. It would be nice if the publisher noticed that those didn't exist yet and did the right thing.

tags: added: derivation
Jeroen T. Vermeulen (jtv) wrote :

The work on bug 777941 will resolve this.

Changed in launchpad:
status: Triaged → In Progress
assignee: nobody → Jeroen T. Vermeulen (jtv)
milestone: none → 11.05
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Curtis Hovey (sinzui) on 2011-05-06
Changed in launchpad:
milestone: 11.05 → 11.06
William Grant (wgrant) on 2011-05-10
tags: added: qa-untestable
removed: qa-needstesting
William Grant (wgrant) on 2011-05-26
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers