Float issues with a project bugs homepage

Bug #551915 reported by Jonathan Lange on 2010-03-30
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Deryck Hodge

Bug Description

If you go to the Bugs tab of a project with no bugs in a browser like Chrome or Safari, the text saying "There are currently no hot bugs filed against Project" is rendered really strangely. It should look the same on those browsers as it does on firefox.

Related branches

Jonathan Lange (jml) wrote :
Deryck Hodge (deryck) wrote :

Oddly, I don't have this issue, even with a large monitor and resolution. Perhaps some difference of installed fonts, too.

But FWIW, the layout of these pages is very fragile. I've been wanting to work on this a bit anyway,

Changed in malone:
status: New → Triaged
importance: Undecided → Low
tags: added: css ui
Deryck Hodge (deryck) wrote :

Float issues abound with this page and are not limited to browser. Each browser shows the problem differently, but the problem is that we don't do floating correctly for these pages.

summary: - Bad rendering in WebKit browsers on bug frontpage when there are no open
- bugs
+ Float issues with a project bugs homepage
Deryck Hodge (deryck) on 2010-05-07
Changed in malone:
status: Triaged → In Progress
assignee: nobody → Deryck Hodge (deryck)
milestone: none → 10.05
Deryck Hodge (deryck) wrote :

This screenie demonstrates the fix, which is that I moved out the bug supervisor and security contact to the portlet. I also fixed the HTML to not user floats now.

Changed in malone:
status: In Progress → Fix Committed
tags: added: qa-needstesting
Deryck Hodge (deryck) on 2010-05-19
tags: added: qa-ok
removed: qa-needstesting
Curtis Hovey (sinzui) on 2010-06-02
Changed in malone:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers