Adding team 'Foo' as a member of team 'Bar' should require confirmation from one of the administrators of 'Foo'

Bug #53637 reported by Guilherme Salgado on 2006-07-21
6
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Guilherme Salgado

Bug Description

As pointed out by James Troup, this can be a problem in some cases:

<elmo> or, in a real world example, a joke translation group called ubuntu-l10n-en-us-fargo added a non-joke translation group ubuntu-l10n-en-gb to themselves, making the en-gb look like the joke en-us-fargo is

So, as a solution to this, I propose requiring one of the admins of the team that is being added as a member to confirm the new membership before it's done. This confirmation wouldn't be necessary if the user that is adding the team as a member has also permission to confirm the new membership.

This is somewhat similar to bug 29863.

Changed in launchpad:
importance: Untriaged → Low
status: Unconfirmed → Confirmed
Sridhar Dhanapalan (sridhar) wrote :

I am an admin for ubuntu-l10n-en-gb and a member of ubuntu-l10n-en-au.

Unfortunately, this prank was not harmless. When I initially applied for a ubuntu-l10n-eng mailing list, I was rejected because of our (the ubuntu-l10n-en-gb team) membership of this group. Fortunately, after an objection from myself, the mail server admin recognised the bug and granted us the list. We were lucky - it could have been much worse.

Diogo Matsubara (matsubara) wrote :

Today we had an example of how the lack of confirmation between team membership subscription could cause much annoyance.

The ubuntu-audio team added ubuntu-kernel-team as one of its members. Someone from the ubuntu-audio team subscribed it as a support contact for launchpad. Every support request filed against launchpad was also spammed to the ubuntu-kernel-team members.
Members of ubuntu-kernel-team couldn't unsubscribe ubuntu-audio from being a support contact for launchpad. (bug 68732)

Changed in launchpad:
importance: Low → High
Changed in launchpad:
assignee: nobody → salgado
Christian Reis (kiko) on 2006-10-28
Changed in launchpad:
assignee: salgado → nobody
Christian Reis (kiko) on 2006-10-30
Changed in launchpad:
assignee: nobody → salgado
Guilherme Salgado (salgado) wrote :

How about team Foo having a page which lists all teams that want to have it as a member and the person (admin from the other team) which tried to add it as the member. This page would be accessible only to admins of Foo and there they'd be able to accept/decline/hold the membership.

Changed in launchpad:
status: Confirmed → In Progress
Joey Stanford (joey) wrote :

For traceback purposes, Bug 110108 is related in that once a team is subscribed to another team, there is no way for the admin to unsubscribe.

Changed in launchpad:
status: In Progress → Fix Committed
Guilherme Salgado (salgado) wrote :

fixed in RF 4289

Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers