Display of Component on distro source summary page may be wrong (but we know the right value)

Bug #521722 reported by Emmet Hikory on 2010-02-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Colin Watson

Bug Description

The Component entry shown on the distro source package summary page appears to be the component that was set at the time of the last upload, but bears no explicit relation to the component in any given distroseries. https://launchpad.net/ubuntu/+source/libjdic-java is an example.

Since the "Latest upload" is shown, and the component is correcly displayed for that upload in recent distroseries summaries, the overall summary page should present the component of the latest upload in the latest distroseries. This is much more likely to be correct.

Related branches

Julian Edwards (julian-edwards) wrote :

The page says:

"*actual publishing details may vary in this distribution, these are just the package defaults. "

This is by design, so you can see that it was overridden. Would you rather it completely hid the maintainer defaults?

Changed in soyuz:
status: New → Incomplete
Emmet Hikory (persia) wrote :

There are no "maintainer defaults" here. There is nothing stored within the source package that identifies which component should be used: that information exists solely within Soyuz. In fact, Soyuz rejects uploads if one attempts to express a default with an "Invalid Section" message.

What I would like is for "Component" on the main page to represent Soyuz's current view of the component in which an upload would be accepted if one were submitted.

Julian Edwards (julian-edwards) wrote :

> There are no "maintainer defaults" here. There is nothing stored within the source package that identifies which component should be used:

That's not exactly true - the uploader will have specified a component in the changes file. While not strictly in the source itself, it's still data supplied to Soyuz, it doesn't exist "solely within Soyuz."

The information you want is on each series presented on that page. The most sensible solution is to remove the Component completely from the top section, since the component could be different depending on which series you're uploading to.

Changed in soyuz:
status: Incomplete → Triaged
importance: Undecided → Low
tags: added: trivial ui
Emmet Hikory (persia) wrote :

None of the ,changes files I have locally contain any Component: header. Where in the .changes file is this usually expressed? The only place I've seen it is in a mangled Section: (e.g. Section: universe/misc), but this is only present in binary uploads typically (I believe accomplished with pkgbinarymangler), and specifically discouraged from use in source uploads.

Colin Watson (cjwatson) on 2015-09-04
Changed in launchpad:
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Colin Watson (cjwatson) on 2015-09-07
tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson) on 2015-09-10
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers