Windmill tests slow down a lot when launchpad.js is greater than 512 000 bytes

Bug #519744 reported by Björn Tillenius on 2010-02-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Unassigned

Bug Description

If our launchpad.js file (which contains all our Javascript files combined) gets bigger than 512 000 bytes, running the Windmill tests suddenly uses up 100% of CPU, and a lot of tests start to fail due to this slowness. We don't why this is happening, but we know that adding whitespace to launchpad.js to make it larger than 512 000 bytes is enough to reproduce this issue.

Daira Hopwood (daira) wrote :

I'd suspect the code at http://github.com/windmill/windmill/blob/master/windmill/server/proxy.py#L54 . Try increasing that 512000 as a workaround.

Note: I'm not a Windmill developer, I was evaluating it for our project (Tahoe-LAFS) and just happened to stumble across this when browsing the code.

On Wed, Mar 17, 2010 at 09:49:24PM -0000, David-Sarah Hopwood wrote:
> I'd suspect the code at
> http://github.com/windmill/windmill/blob/master/windmill/server/proxy.py#L54
> . Try increasing that 512000 as a workaround.

Thanks! That indeed looks to be the issue. I'll test to confirm it, and
will try fix Windmill to do something more sensible.

    assignee bjornt

Changed in launchpad-foundations:
assignee: nobody → Björn Tillenius (bjornt)
Changed in launchpad-foundations:
assignee: Björn Tillenius (bjornt) → nobody
Māris Fogels (mars) wrote :

We fixed this in our test suite by adding a warning if the combined JS exceeds 512KB, and by some judicious pruning of what we ship over the wire.

Changed in launchpad-foundations:
status: Triaged → Fix Released
Deryck Hodge (deryck) wrote :

Marking Triaged, since this is still a problem for us.

Changed in launchpad-foundations:
status: Fix Released → Triaged
Curtis Hovey (sinzui) wrote :

Windlmill is dead.

Changed in launchpad:
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers