Linux Distribution field should be a neutral default

Reported by Joachim Noreiko on 2006-06-16
12
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Björn Tillenius

Bug Description

I just accidentally filed a bug in Baltix because I hadn't noticed the field, and that was the default.

To prevent many users doing this, set the field to "Choose a distro" by default, and check the user has set the field to something else when they submit.

Matthew Paul Thomas (mpt) wrote :

An alternative would be to make the default "Ubuntu" -- that wouldn't be a neutral default, but it would be correct much more often. That might lead people to ignore it, but that would be an issue only for people who frequently report bugs on multiple distributions...

Changed in malone:
importance: Untriaged → Low
status: Unconfirmed → Confirmed
Christian Reis (kiko) wrote :

I'm not sure what the right solution here is yet, but this should be on the radar. Assigning to Bjorn who will be dealing with changes in this area shortly.

Changed in malone:
assignee: nobody → bjornt
importance: Low → High

When clicking "also affects... distro", the distro field should be set to the current distro, which is most likely to be right. (or there should be an also affects... other package option).

Christian Reis (kiko) wrote :

I think the latter option is more correct, but I actually think that bug 1334 is more on the ball as to the right general solution here.

Brad Bollenbach (bradb) wrote :

I propose a simpler, incremental solution: add a "jump to distribution" box on the front page, like we already have for products.

This is simpler because it means maintaining one less bug reporting form/workflow, and comes in handy for my work on the guided filebug workflow, because it means not having to maintain a separate guided bug workflow too. :)

Thoughts?

Björn Tillenius (bjornt) wrote :

As per Matthew's suggestion, Ubuntu is now the initially selected distribution.

Changed in malone:
status: Confirmed → Fix Released
Bruce Cowan (bruce89) wrote :

This is no longer the case, see Bug #39462 for an example of Baltix being used by mistake.

Changed in malone:
status: Fix Released → Confirmed
Christian Reis (kiko) wrote :

Bruce, please file a new bug with a description of the problem, including the URL you can see this happening at. This bug /was/ fixed, but there are other places where the distribution drop-down is used.

Changed in malone:
status: Confirmed → Fix Released
Christian Reis (kiko) wrote :

(For the record, the Also Affects.. Distribution link does default to alphabetical order, which is likely to be what Bruce noticed.)

Matthew Paul Thomas (mpt) wrote :

(Bruce reported the problem with "Also affects distribution" as bug 151014.)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers