buildd-manager is reluctant on shutting down in a timely manner

Bug #497282 reported by Steve McInerney on 2009-12-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Julian Edwards

Bug Description

2009-12-16 04:37:04+0000 [-] Received SIGTERM, shutting down.
2009-12-16 04:43:08+0000 [-] Server Shut Down.

6 minutes???
 -gt 30 seconds is kill -9 territory.

Is this expected behaviour? Why so long?

Related branches

Julian Edwards (julian-edwards) wrote :

It's probably waiting for a child process to complete - it kicks off process-upload for build uploads which can take ages. I've never seen this behaviour on dogfood, so I'm not sure why it does it on production though.

Why did you need to shut it down today?

Changed in soyuz:
status: New → Triaged
importance: Undecided → Low
tags: added: buildd-manager
tags: added: soyuz-build
Julian Edwards (julian-edwards) wrote :

Setting to low priority since I'm happy for it to end up as a kill -9.

Changed in soyuz:
status: Triaged → In Progress
assignee: nobody → Julian Edwards (julian-edwards)
Brad Crittenden (bac) on 2010-10-27
tags: added: bad-commit-11801
Changed in soyuz:
milestone: none → 10.11
tags: added: qa-needstesting
Changed in soyuz:
status: In Progress → Fix Committed
tags: added: qa-ok
removed: qa-needstesting
Launchpad QA Bot (lpqabot) wrote :

Fixed in stable r11815 (http://bazaar.launchpad.net/~launchpad-pqm/launchpad/stable/revision/11815) by a commit, but not testable.

tags: added: qa-untestable
removed: qa-ok
Robert Collins (lifeless) wrote :

Needs a deployment to the buildd-manager machine to fix-release this.

Launchpad QA Bot (lpqabot) wrote :

Fixed in stable r11815 (http://bazaar.launchpad.net/~launchpad-pqm/launchpad/stable/revision/11815) by a commit, but not testable.

Changed in soyuz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers