Inline dupe-finder resets itself randomly

Reported by John A Meinel on 2009-12-12
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Graham Binns

Bug Description

For some reason now with the new inline dupe finder the bug submission page
decides to *completely* reset it self after XX seconds.

This means that after I've spent several minutes trying to submit a nice well
crafted bug submission, I lose *everything* before I get a chance to submit.

Because the ajax code destroys the message box I've been typing in, I can find
no way to restore the text. (back/forward certainly don't work, hitting Next
again doesn't work.)

Steps to reproduce:

 1) Fill in the summary, click Next
 2) Start trying to write a fairly descriptive bug report
 3) Scroll down, maybe edit a bit more
 4) Page resets, back to just the "Summary: [ ] Next" view. It does seem to
 preseve the text in the Summary message.

John A Meinel (jameinel) wrote :

I should also mention that I have a bit of a flakey network, where new connections are sometimes denied. If I stay connected to IRC/ssh etc, the connection continues to work, but loading a *new* web page fails to connect to the new host. So I suppose it is possible that there is some sort of background thread trying to read from launchpad, and when it times out, it resets the page rather than leaving me alone.

description: updated
John A Meinel (jameinel) wrote :

Note that in the process of submitting this bug, the page reset on me 2 or 3 times, and while trying to submit bug #495979 (not related) it reset 4 times before I actually finished submitting. I've now taken to writing all my bug submissions in a text editor and copy and pasting until I actually manage to get the bug posted.

Graham Binns (gmb) wrote :

I'll work on trying to reproduce this.

In the meantime, you can work around it by disabling Javascript when you hit the +filebug page, which will mean that the page goes back to the old style two-step process (though that will mean that any suggested dupes are all expanded; at least it'll work).

We should also probably add a means by which users can bypass the inline version of the dupe finder if necessary, say by adding ?no-async-dupefinder=1 to the URL or something.

Changed in malone:
status: New → Incomplete
assignee: nobody → Graham Binns (gmb)
summary: - Inline dupe-finding: an exercise in pain
+ Inline dupe-finder resets itself randomly
Graham Binns (gmb) wrote :

It sounds like the reset_filebug_form() function is getting called. This might be the result of a bug that was fixed as part of bug 494732, whereby the function got hooked up to every onchange handler on the page - so any change = reset.

The only way for John to really test to see if that fix deals with his problem too is is to wait for edge to update again - the revision in question (devel r10043) should hit edge tomorrow.

John, could I trouble you to try this again tomorrow or Monday to see if your problem gets resolved? We're annoyingly only two revisions behind the fix here, but with it being a weekend I can't make a special request for an edge update.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Graham Binns wrote:
> It sounds like the reset_filebug_form() function is getting called. This
> might be the result of a bug that was fixed as part of bug 494732,
> whereby the function got hooked up to every onchange handler on the page
> - so any change = reset.
>
> The only way for John to really test to see if that fix deals with his
> problem too is is to wait for edge to update again - the revision in
> question (devel r10043) should hit edge tomorrow.
>
> John, could I trouble you to try this again tomorrow or Monday to see if
> your problem gets resolved? We're annoyingly only two revisions behind
> the fix here, but with it being a weekend I can't make a special request
> for an edge update.

Will do.

any change = reset seems ... bad. Probably not until Monday, but I
submit enough bug reports that I'll probably be doing it anyway. :)

John
=:->

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (Cygwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAkskACoACgkQJdeBCYSNAANW1wCgw/AppQCVzhFr8Wk20XdKxnq2
dwkAoJoK4rV3g6LxweIuulwOri/acqIS
=viFE
-----END PGP SIGNATURE-----

Graham Binns (gmb) wrote :

2009/12/12 John A Meinel <email address hidden>:
> Will do.
>
> any change = reset seems ... bad. Probably not until Monday, but I
> submit enough bug reports that I'll probably be doing it anyway. :)
>

Yes. Annoyingly, the wrongness of the statement that caused the
problem wasn't obvious until after the branch containing the bug had
already landed.

Graham Binns (gmb) wrote :

Edge should now have the fix that I mentioned. I haven't been able to reproduce this yet myself; could one of the people who have been able to reproduce it before try again and see whether it's been resolved?.

If you're still seeing the problem you can work around it by going to https://launchpad.net and disabling the edge redirect so that you're only using the stable version of Launchpad.

John A Meinel (jameinel) wrote :

I can confirm that following the steps I was doing earlier no longer breaks.

I did not try to do as big of a bug submission as I did earlier, but certainly if the problem shows up again, I'll comment here.

Graham Binns (gmb) wrote :

Excellent, thanks John. I'll mark this as Fix committed for now and we can re-open it if necessary.

Changed in malone:
status: Incomplete → Fix Committed
milestone: none → 3.1.12
Deryck Hodge (deryck) on 2009-12-21
Changed in malone:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers