License details for "Other" are displayed even if not selected

Bug #490148 reported by Matt Giuca on 2009-11-29
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

If I select in the edit page for a project, eg. https://launchpad.net/example/+edit, the license Other/Proprietary or Other/Open Source, a text box appears where I can describe my license, e.g., "My Hand-Made License".

Now if I uncheck both of the "Other" checkboxes and select another license, e.g., GNU GPL v3, now on my project page the Licenses appears as "GNU GPL v3, My Hand-Made License."

The text I entered in the "Other" text field should not be displayed on the project page if the Other checkbox is not selected. It should possibly not even be remembered.

Related branches

Curtis Hovey (sinzui) wrote :

This behaviour is by design. User may include additional information such as that the maintainer can be contacted about relicensing.

affects: launchpad → launchpad-registry
Changed in launchpad-registry:
status: New → Won't Fix
Matt Giuca (mgiuca) wrote :

Thanks for your reply Curtis,

Well, if it's by design that the "Other" field is still displayed even if Other checkbox is unchecked, then the text field *should* be visible on the Edit page even if the Other checkbox is unchecked. If it's intended to be used the way you say (for additional information), then the text box does not belong to the "Other" license types, it is a separate field on the project page.

At present, if I wish to add additional information about licensing, I have to go to edit, check "Other/Open Source", type the extra information, and then uncheck "Other/Open Source" again.

In another use case (which is how I discovered the bug), I can see additional information about licensing on the project page, but if I click Edit, there is absolutely no way for me to see or edit the text field. I have to try checking every box on the page to discover that I had to check "Other/Open Source" to bring the text field up.

I think this definitely qualifies as confusing UI.

Curtis Hovey (sinzui) wrote :

The confusing-ui is justification that something can be done to make this a better experience. I am re-opening the bug.

Changed in launchpad-registry:
importance: Undecided → Low
status: Won't Fix → Triaged
Curtis Hovey (sinzui) on 2011-03-07
Changed in launchpad:
milestone: none → 11.04
assignee: nobody → Curtis Hovey (sinzui)
status: Triaged → In Progress
tags: added: chr
Launchpad QA Bot (lpqabot) wrote :
Changed in launchpad:
milestone: 11.04 → 11.03
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Curtis Hovey (sinzui) on 2011-03-08
tags: added: qa-ok
removed: qa-needstesting
Curtis Hovey (sinzui) on 2011-03-10
Changed in launchpad:
status: Fix Committed → Fix Released
Curtis Hovey (sinzui) on 2017-05-15
Changed in launchpad:
assignee: Curtis Hovey (sinzui) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers