OOPS changing the version number in the administer interface for a product release

Bug #4750 reported by Carlos Perelló Marín
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Edwin Grubbs

Bug Description

Steps to reproduce:
1. Open http://launchpad.dev/firefox/trunk/0.9.2/+review
2. Change the version to 0.9.3
3. Click Change
4. OOPS-604E140 ForbiddenAttribute ('__module__', <class 'canonical.launchpad.database.productrelease.ProductRelease'>)
TypeError("Can't set values on read-only fields "

Recent OOPSes: OOPS-1066EC138

Dafydd Harries (daf)
Changed in launchpad:
status: Unconfirmed → Confirmed
description: updated
Changed in launchpad:
milestone: none → 1.1.11
Christian Reis (kiko)
Changed in launchpad:
assignee: nobody → kiko
Revision history for this message
Diogo Matsubara (matsubara) wrote :

re-targeting to .12

Changed in launchpad:
milestone: 1.1.11 → 1.1.12
Revision history for this message
Diogo Matsubara (matsubara) wrote :

Since this wasn't fixed for 1.1.12, I'm removing the milestone. Kiko, please re-assess and set a new milestone

Changed in launchpad:
milestone: 1.1.12 → none
Revision history for this message
Curtis Hovey (sinzui) wrote :

This bug should be fixed in conjunction with bug 174468. Since the version number will become the milestone name, I think we want make sure that the admin can edit the milestone name (when editing the milestone).

Changed in launchpad-foundations:
assignee: kiko → edwin-grubbs
milestone: none → 2.1.12
status: Confirmed → Triaged
milestone: 2.1.12 → none
Curtis Hovey (sinzui)
Changed in launchpad-registry:
milestone: none → 2.1.12
Ursula Junque (ursinha)
description: updated
Curtis Hovey (sinzui)
Changed in launchpad-registry:
milestone: 2.1.12 → 2.2.1
Curtis Hovey (sinzui)
Changed in launchpad-registry:
status: Triaged → In Progress
importance: Medium → Low
Curtis Hovey (sinzui)
Changed in launchpad-registry:
milestone: 2.2.1 → 2.2.2
Changed in launchpad-registry:
milestone: 2.2.2 → 2.2.3
Revision history for this message
Edwin Grubbs (edwin-grubbs) wrote :

Landed in rev 7801 in db-devel branch.
revision-id:<email address hidden>

Changed in launchpad-registry:
status: In Progress → Fix Committed
Changed in launchpad-registry:
status: Fix Committed → Fix Released
Curtis Hovey (sinzui)
visibility: private → public
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers