milestone content exceeds the browser viewport

Bug #473738 reported by John A Meinel on 2009-11-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Unassigned

Bug Description

There seems to be an odd resizing bug on the +milestone page.

I went to:
https://edge.launchpad.net/bzr/+milestone/2.0.1

And I wanted to check the 'Fix Committed/Fix Released' status for various bugs. However, that information has been resized off the right of the screen. (I'll attach a screenshot).

So I expanded the window, and it resized something in the middle, rather than letting me see all fields.

Also note that in both screenshots the bug report goes to '...' before it even gets to the full width of the column. In fact, the '...' never changes. As near as I can tell, it just adds more whitespace the wider I try to make my browser.

I assume this is most likely a CSS sort of bug. So my browser is Firefox 3.5.4 on Windows Vista.

Related branches

John A Meinel (jameinel) wrote :
John A Meinel (jameinel) wrote :
summary: - milestone page refuses to let me see the bug status
+ milestone page refuses to let me see the bug status (after resizing)

Usually, the registry team handles milestones, even though it contains a bug list.

affects: malone → launchpad-registry
Curtis Hovey (sinzui) wrote :

Recent changes to the milestone-index template placed a .full-page-width class inside another. The second is sizing itself on downloads table. The problem is not visible when the table is not present.

Changed in launchpad-registry:
assignee: nobody → Curtis Hovey (sinzui)
importance: Undecided → High
status: New → In Progress
Curtis Hovey (sinzui) wrote :

The <div style="clear:both" /> are weill formed but invalid HTML. FF saw two open divs, so it rendered the side portlets below the main content. This then exposed a flaw in nested .full-page-width that caused the content to exceed the browser viewport. Fixing the markup is all that is requried, but added an additional rule for nested .full-page-width is the right thing to do since the content should never exceed the vew port.

summary: - milestone page refuses to let me see the bug status (after resizing)
+ milestone content exceeds the browser viewport
Curtis Hovey (sinzui) on 2009-11-04
Changed in launchpad-registry:
milestone: none → 3.1.10
Curtis Hovey (sinzui) wrote :

Fixed in launchpad db-devel r8642.

Changed in launchpad-registry:
status: In Progress → Fix Committed

Fixed released in launchpad-project 3.1.10.

Changed in launchpad-registry:
status: Fix Committed → Fix Released
Curtis Hovey (sinzui) on 2017-05-15
Changed in launchpad:
assignee: Curtis Hovey (sinzui) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers