No option to purge list archives when purging a mailing list

Bug #471274 reported by Tom Haddon on 2009-11-02
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

When deleting a mailing list in LP, the archive isn't deleted. Visitors can still visit the archives on the web interface. By delete we mean the final status where we mean to destroy Lp's knowledge of the list.

See also bug 817794 which is about expunging the archive without deleting the list.

Tom Haddon (mthaddon) on 2009-11-02
Changed in launchpad:
importance: Undecided → High
status: New → Confirmed
Joey Stanford (joey) on 2009-11-02
tags: added: oem-services
Barry Warsaw (barry) wrote :

This is working as designed. Since the vast majority of mailing lists are public, and we never want to delete the public record, we purposefully do not ever delete archives.

A valid wishlist might be:

Provide an option to delete a mailing list's archive through the user interface. This option should only be made available to mailing-list-experts.

Changed in launchpad:
status: Confirmed → Invalid
Tom Haddon (mthaddon) wrote :

I've changed the focus of the bug, and switched it back from invalid to confirmed.

summary: - Purging a mailing list doesn't purge the archives
+ No option to purge list archives when purging a mailing list
Changed in launchpad:
status: Invalid → Confirmed
affects: launchpad → launchpad-registry
tags: added: mailing-lists
Curtis Hovey (sinzui) on 2009-11-06
Changed in launchpad-registry:
status: Confirmed → Triaged
importance: High → Low
tags: added: feature
Tom Haddon (mthaddon) on 2010-05-28
tags: added: canonical-losa-lp
description: updated
description: updated
Curtis Hovey (sinzui) on 2011-07-28
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers