"special symbols" when people copy-paste text from original to translation

Bug #46 reported by Jan Claeys on 2005-01-11
20
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Carlos Perelló Marín

Bug Description

When people copy-paste text from the original text to the translation edit box, that may include special symbols used to indicate carriage returns and leading / trailing spaces. These special symbols aren't always cleaned out correctly.

One possible solution to solve this problem would be to provide a button to insert the original text into the translation edit control. That way sensible people won't copy-past it themselves anymore, and the problem would go away mostly...

Carlos Perelló Marín (carlos) wrote :

We have a spec that talks about it at:

https://launchpad.net/products/rosetta/+spec/translation-reviews

It will be implemented in the next three months.

Changed in rosetta:
assignee: nobody → carlos
status: New → Accepted
Dafydd Harries (daf) wrote :

I think we should remove or replace certain special characters when the form is submitted. Existing ones should be removed from the database, similarly to what we did for carriage returns in translations.

Christian Reis (kiko) wrote :

Oops because this crashes exports.

Carlos Perelló Marín (carlos) wrote :

People keeps using copy&paste and polluting translations, this should be fixed as soon as possible...

Martin Pitt (pitti) wrote :

I agree, we already saw several Ubuntu bugs due to this problem. However, a button to put a suggestion into the text field would be highly appreciated, too.

Jan Claeys (janc) wrote :

Removing/replacing special characters might cause problems too (what if upstream used those characters?). It would be good to check the untranslated string for those characters first.

And a button to copy a suggestion would be great indeed... :-)

BTW: the "initial reporter" link in the "bug details" box at the left is broken? (Probably I should file a bug about that.)

On Fri, May 26, 2006 at 05:29:38AM -0000, Jan Claeys wrote:
> BTW: the "initial reporter" link in the "bug details" box at the left is
> broken? (Probably I should file a bug about that.)

Thanks for pointing that out, filed bug 46757.

The English (United Kingdom) translation team is using a greasemonkey script to add copy buttons to rosetta.

https://lists.ubuntu.com/archives/ubuntu-l10n-eng/2006-August/000058.html

The script removes/replaces the special symbols.

Changed in rosetta:
assignee: carlos → mpt
status: Confirmed → In Progress
Changed in rosetta:
status: In Progress → Fix Committed
Changed in rosetta:
status: Fix Committed → Fix Released
Carlos Perelló Marín (carlos) wrote :

Reopen as data was not fixed and we need to cleanup our database.

Changed in rosetta:
assignee: mpt → carlos
status: Fix Released → In Progress
Matthew Paul Thomas (mpt) wrote :

That seems like a separate bug to me.

We migrated all data last week.

Changed in rosetta:
status: In Progress → Fix Released
tags: added: iso-testing
tags: removed: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Related blueprints