Distroseries:+index page timing out

Bug #458169 reported by Ursula Junque on 2009-10-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Edwin Grubbs

Bug Description

We are having lots of timeouts in the Distroseries:+index pages, about 1500 yesterday and 3000 today.

Some of them: OOPS-1390A1002, OOPS-1390A1169, OOPS-1390A385

Related branches

Curtis Hovey (sinzui) on 2009-10-22
Changed in launchpad-registry:
milestone: none → 3.1.10
importance: Undecided → High
status: New → Triaged
assignee: nobody → Edwin Grubbs (edwin-grubbs)
Curtis Hovey (sinzui) wrote :

The oops report makes me think this is a duplicate of bug 455812. I do not know why we are doing thousands of queries for distroseries when there is only one to see.

Edwin Grubbs (edwin-grubbs) wrote :

There are only 26 repititions of the distroseries query for a total time of 6846ms. The non-sql time is 15 seconds versus 7.7 seconds for total sql time, which should be accurate since the last query averaged only 263ms, so the fact that the oops doesn't add the interrupted query time to the total sql time won't matter. It looks like there is a lot of python processing or waiting on something else besides the db.

Curtis Hovey (sinzui) wrote :

flacoste points out that Distroseries.currentseries is problematic.

Curtis Hovey (sinzui) on 2009-10-23
Changed in launchpad-registry:
status: Triaged → In Progress
Changed in launchpad-registry:
status: In Progress → Fix Committed
Curtis Hovey (sinzui) on 2009-11-02
Changed in launchpad-registry:
status: Fix Committed → In Progress
Ursula Junque (ursinha) on 2009-11-02
tags: added: current-rollout-blocker
Curtis Hovey (sinzui) on 2009-11-04
Changed in launchpad-registry:
status: In Progress → Fix Committed

Fixed released in launchpad-project 3.1.10.

Changed in launchpad-registry:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers