internal error notifying merge proposal

Bug #453529 reported by Bo Laurent on 2009-10-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Tim Penhey

Bug Description

The last two times I created merge proposals, I get internal errors which prevented lpad from notifying the reviewer.

Launchpad encountered an internal error during the following operation: notifying people about the proposal to merge lp:~canonical-isd-hackers/canonical-salesforce/450486-dell-asset-pricing into lp:~sfi-team/canonical-salesforce/trunk. It was logged with id OOPS-1385MPCJ4. Sorry for the inconvenience.

The exception in shown in the oops: OSError: [Errno 39] Directory not empty: '/tmp/bzr-limbo-Gznmvg/new-2'

Bo Laurent (shikibu) wrote :
tags: added: code-review email oops
affects: launchpad → launchpad-code
description: updated
Aaron Bentley (abentley) wrote :

The root cause is that you are trying to merge two unrelated branches, so you probably want to re-think your request.

However, there is a branch in progress that will allow you to actually do this crazy thing, rather than getting oopses.

Changed in launchpad-code:
status: New → Triaged
importance: Undecided → High
Martin Albisetti (beuno) wrote :

Launchpad encountered an internal error during the following operation: notifying people about the proposal to merge lp:~beuno/loggerhead/yui3-0-0 into lp:loggerhead. It was logged with id OOPS-1390MPCJ4. Sorry for the inconvenience.

They don't seem to be unrelated in my case.

Tim Penhey (thumper) wrote :

A fix is in the process of being cherry picked into the production environment. Just have to wait for the tests to run...

I'll update this bug when the fix is released.

Changed in launchpad-code:
assignee: nobody → Tim Penhey (thumper)
milestone: none → 3.1.10
status: Triaged → In Progress
Tim Penhey (thumper) on 2009-10-29
Changed in launchpad-code:
status: In Progress → Fix Committed
Changed in launchpad-code:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers