limited upload rights no longer give series nomination accept/decline rights

Bug #451390 reported by Andy Whitcroft on 2009-10-14
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
William Grant
ubuntu-community
Undecided
Ubuntu Technical Board

Bug Description

I have limited upload rights to the kernel packages. When I first had this I could accept/decline series nominations for those packages. Somewhen recently this ability has stopped working, the accept/decline markers have gone away again. This affects both apw and stefan-bader-canonical; we both have kernel upload rights.

It is possible that this stopped working in step with our upload rights movingg from being directly attached to me in acls list, to being attached indirectly via a 'group' (this is likely not the official term).

The original bug to get this added was bug #373172, it is possible this is related to bug #376006.

Related branches

Andy Whitcroft (apw) wrote :

Note that the above was tested on edge. Just checked on www.launchpad.net and the issue appears the same there.

Changed in malone:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Tom Berger (intellectronica)
milestone: none → 3.1.10
Deryck Hodge (deryck) on 2009-11-02
Changed in malone:
milestone: 3.1.10 → 3.1.11
Changed in malone:
assignee: Tom Berger (intellectronica) → nobody
Changed in malone:
milestone: 3.1.11 → 3.1.12
Deryck Hodge (deryck) wrote :

Un-assigning to milestone because we're no longer targeting bugs to milestones until they are ready to land. This is no indication in a change of priority for fixing this.

Changed in malone:
milestone: 3.1.12 → none
Andy Whitcroft (apw) wrote :

/me wonders if there is any timescale for this fix. this is a pretty significant part of the utility of package sets and those are the direction that all upload rights are moving. You may find this becomes suddenly very urgent on you.

Deryck Hodge (deryck) on 2010-06-14
tags: added: dhrb
Jonathan Lange (jml) wrote :

Note that there are now public methods for checking to see whether a person has upload permissions (see IArchive.checkUpload and others), and that IBugNomination.canApprove implements its own version. This duplication is perhaps the source of this bug.

Colin Watson (cjwatson) wrote :

We've raised this as part of the (long and complicated) discussion around bug 174375.

tags: added: escalated
Francis J. Lacoste (flacoste) wrote :

Escalated on the stakedholders list.

Matt Zimmerman (mdz) on 2011-03-10
Changed in ubuntu-community:
assignee: nobody → Ubuntu Technical Board (techboard)
Changed in launchpad:
importance: High → Critical
Kees Cook (kees) wrote :

This bug got hit again today. I've added brad-figg to ubuntu-drivers for now (to gain bugtask series nomination approval super-powers).

William Grant (wgrant) on 2011-05-09
Changed in launchpad:
assignee: nobody → William Grant (wgrant)
status: Triaged → In Progress
Launchpad QA Bot (lpqabot) wrote :
Changed in launchpad:
milestone: none → 11.05
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
William Grant (wgrant) wrote :

+nominations still doesn't render on qastaging. But while each nomination is now roughly 7 queries instead of 5, the new queries are 3-4ms and still dominated by latest_published_component.

tags: added: qa-ok
removed: qa-needstesting
William Grant (wgrant) on 2011-05-11
Changed in launchpad:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Micah confirmed that this works now, thanks for the fix!

Changed in ubuntu-community:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers