jscheck builder constantly failing on step 1, bzr

Bug #450406 reported by Gavin Panella on 2009-10-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Gavin Panella

Bug Description

From https://lpbuildbot.canonical.com/builders/jscheck/builds/45/steps/bzr/logs/err.text:

{{{
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/buildbot/process/buildstep.py", line 686, in startStep
    d.addCallback(self._startStep_2)
  File "/usr/lib/python2.5/site-packages/twisted/internet/defer.py", line 191, in addCallback
    callbackKeywords=kw)
  File "/usr/lib/python2.5/site-packages/twisted/internet/defer.py", line 182, in addCallbacks
    self._runCallbacks()
  File "/usr/lib/python2.5/site-packages/twisted/internet/defer.py", line 317, in _runCallbacks
    self.result = callback(self.result, *args, **kw)
--- <exception caught here> ---
  File "/usr/lib/python2.5/site-packages/buildbot/process/buildstep.py", line 709, in _startStep_2
    skip = self.start()
  File "/usr/lib/python2.5/site-packages/buildbot/steps/source.py", line 184, in start
    self.startVC(branch, revision, patch)
  File "/usr/lib/python2.5/site-packages/buildbot/steps/source.py", line 826, in startVC
    assert not branch # we need baseURL= to use branches
exceptions.AssertionError:
}}}

The code in which the above error occurs is in buildbot 0.7.9. The same code does appear in later versions, but there have been changes to the module (and elsewhere, naturally) so it's worth upgrading to see if this problem goes away or if the root cause manifests itself in a different way. Currently we're close to running 0.7.11p3.

Gavin Panella (allenap) wrote :

mthaddon landed this today and rolled it out. Seems to be working.

Changed in launchpad-foundations:
assignee: nobody → Gavin Panella (allenap)
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.