Search string causes syntax error in full text engine

Bug #44913 reported by Diogo Matsubara on 2006-05-15
4
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Stuart Bishop

Bug Description

Steps to reproduce:

1. http://localhost:8086/distros/ubuntu/+bugs
2. Fill in the search string: ‘a.a’
3. Crash similar to this: OOPS-134C118

Changed in launchpad:
status: Unconfirmed → Confirmed
assignee: nobody → stub
Revision history for this message
Diogo Matsubara (matsubara) wrote :

Another search string that causes an oops: a)a
OOPS-143C426

Revision history for this message
Diogo Matsubara (matsubara) wrote :

And another one: a-aç
OOPS-146D1069

Revision history for this message
Diogo Matsubara (matsubara) wrote :

Another one: a-a”
OOPS-156C510

Revision history for this message
Stuart Bishop (stub) wrote :

Looks like two seperate bugs here - the a)a one is different to the others which all involve Unicode characters and the special hyphenation and period handling code.

Changed in launchpad:
status: Confirmed → In Progress
Stuart Bishop (stub) on 2006-06-08
Changed in launchpad:
status: In Progress → Fix Committed
Stuart Bishop (stub) on 2006-06-15
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers