For approval conflicts, log the competing package names.

Bug #448019 reported by Jeroen T. Vermeulen on 2009-10-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Medium
Jeroen T. Vermeulen

Bug Description

When an upload can't be approved because its destination package is unknown and multiple packages have templates with a domain matching that for the upload, the approver logs a conflict warning:

"Found multiple templates with translation domain 'foo'. There should be only one."

In practical terms, this happens whenever KDE templates move from one package to another (because we don't really move stuff; we receive a new copy in a different place. The warning goes to the Launchpad error-reports list, and the Rosetta team reports them to the Ubuntu Translations Coordinators. They can investigate which of the matching templates is the current one, and disable the rest.

But fixing the problem isn't easy for the UTC since they don't know what the matching packages are. That currently involves a manual lookup of some sort. The logged message should name the source packages and distroseries (and maybe even link to them for convenience).

When fixing this, also consider bug 447754.

Related branches

Jeroen T. Vermeulen (jtv) wrote :

This will save everyone some time when KDE templates move about.

Changed in rosetta:
assignee: nobody → Jeroen T. Vermeulen (jtv)
milestone: none → 3.1.10
status: Triaged → In Progress
description: updated
description: updated
Jeroen T. Vermeulen (jtv) wrote :

Fixed in devel 9682

Changed in rosetta:
status: In Progress → Fix Committed
Ursula Junque (ursinha) on 2009-10-22
tags: added: qa-needstesting
tags: added: qa-untestable
removed: qa-needstesting
Changed in rosetta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers