Translations should be searchable

Reported by Frederic Wenzel on 2005-01-11
168
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Medium
Данило Шеган

Bug Description

It should be possible to search the original strings and translations for a product or package. There are often multiple strings that should be translated the same way. And search would also make it much easier to find a particular incorrect translation.

The search results should be batched, just as the existing full list of translatable items are.

Andrew Bennetts (spiv) wrote :

Agreed. Here's my use-case:

I use the en_AU locale, so 99% of strings don't need translations for me. It would be handy for me to be able to search for strings "color", so that I can translate just those strings to use "colour", and not have to look at the rest.

pirast (pirast) wrote :

Yupp, I'd like it, too.

Martin

Jeroen (jeroenubuntu) wrote :

I'd like this too. It's easier than downloading the .po, searching it for an error I found in an app and then uploading it again.

Dafydd Harries (daf) on 2005-12-20
Changed in rosetta:
status: New → Accepted
Jakob Malm (malmjakob) wrote :

Several times, I have seen a somewhat awkward translation (Swedish, sv) and wanted to correct it, but I don't know in which package to look for it. It could be a Gnome message, for instance, and there are quite a few Gnome packages to go through...

My suggestion is to make whole projects (such as Gnome) searcheable for a particular string, in any chosen language. Or, that I can somehow choose which (sub-) projects to include in the search, e.g. a few Gnome subprojects or all apt-get related projects.

Jorge Bernal (koke) wrote :

I don't want to be tedious, but I think this is a really blocker for fixing translations. It's almost impossible to fix a typo in a translation if there are > 100 strings (actually it's possible but it's a huge waste of time).

I don't know what priority has this, but 59 weeks old is too old for something as essential as this one.

Carlos Perelló Marín (carlos) wrote :

Yes, this feature is really useful and yes, we are going to implement it but we are working on more urgent fixes/features like improving the imports into Rosetta and improve the review of translations and sharing translations between distributions or upstream.

We already have a spec for this but still needs some extra work: https://launchpad.net/products/rosetta/+spec/translate-specific-string

In the mean time, I suggest you to download the .po file, fix it offline and reupload it into the system.

Cheers.

Jan Claeys (janc) wrote :

> In the mean time, I suggest you to download the .po file,
> fix it offline and reupload it into the system.

Which doesn't fix the problem in the case (reported by Jakob Malm above) where you don't know in what .po file to find the string... ;-)

Igor Zubarev (igor.zubarev) wrote :

Agreed. I will be good for fixing bugs.

Changed in rosetta:
assignee: nobody → danilo
Daniel Hahler (blueyed) wrote :

As far as I can see, you can only upload .po files (which you would have edited offline), if you're a member of the translation team?!

Christian Reis (kiko) on 2006-09-23
Changed in rosetta:
importance: Wishlist → High
Gustaf (opera) wrote :

There are several strings that's incorrect in my language. I have several times tried to use rosetta, but since it's a pain to even find the correct translation page for the specific package/language, when I finally get there, I have to press 'next' for half an hour or so.

This keeps me from fixing translation bugs. I'm absolutely sure you have been blocking hundreds or thousands of people willing to help, for more than a year. You keep blocking them for every day this isn't fixed, and it's so painfully simple to implement a temporary solution, but no, there's nothing. This isn't importance "high", it's "critical". Internationalization must be important, and this kind of (more or less willingly) blocking help on such an important issue. Personally I think: Block Edgy until this is fixed. That would show us that ubuntu really cares about people willing to help.

Matthew Paul Thomas (mpt) wrote :

This is a Launchpad bug, not an Ubuntu bug. They're completely different systems, with completely different development teams. Blocking either on a feature of the other would be pointless. We do understand Rosetta is annoying to use without search, and we plan to introduce it in the next couple of months.

description: updated
Jan Claeys (janc) wrote :

I think it should also be possible to search in all packages and not only inside one package, because it's not always clear which package a certain string is in (e.g. the strings in the GNOME menu).

That's what will we do. Global search and per context search.

Cheers.

Gustaf (opera) wrote :

Different systems yeah, but it's all under Canonical Corp, right? Should be a management decision to prioritize this. But Ok, Edgy is supposed to be unstable, is it might not matter.

www8 (www8) wrote :

Yes, I also agree, that this feature should be created. But does anybody know is it accepted by creators of Launchpad ? I think, this option would be really useful, but when it would be ?

Matthew Paul Thomas (mpt) wrote :

www8, please read existing comments before adding new ones. Thanks.

After all, one possible solution would be to open the rosetta source code. It does not guarantee us that this feature would be implemented faster anyway, but probably it would be since this is a greatly wanted feature.

94 weeks.........

pirast (pirast) wrote :

I want this, too.. Sorry, but this is a very much wanted feature since Rosetta has been released.. Please please, add this feature.

Marco Rodrigues (gothicx) wrote :

Hi!

How about at translation page for example: https://translations.beta.launchpad.net/ubuntu/feisty/+source/dpkg/+pots/dpkg/pt/+translate

In the Show: select box, add in the end something like "by myself".

It filter all translations for that package done by me! It would be a lot easier and can be implemented.. just need to find the name of translator in each package, so it won't make overloads of the machine.

Gerardo Cruz (gcruz) wrote :

Carlos, there isn't much information on the spec, in fact it says "Not started" and the wiki is private. Last comment is from November by sabdfl. Is this blocked or something? Any updates on this? Thanks.

Mark Van den Borre (markvdb) wrote :

Just to say that I would love to see this.

A simple method for searching through a rosetta hosted .po file would have scored us a few fixed translations.

Laur Mõtus (vprints) wrote :

I believe this function to be VERY necessary, it would really speed up the translation process for me.

2007/5/30, Laur Mõtus <email address hidden>:
> I believe this function to be VERY necessary, it would really speed up
> the translation process for me.

seconded.
I mainly abandoned my translation work through rosetta (not upstream)
due to this lack!

Arnaud
--
Linux / Unix Expert - MGE UPS SYSTEMS - R&D Dpt
Network UPS Tools (NUT) Project Leader - http://www.networkupstools.org/
Debian Developer - http://people.debian.org/~aquette/
OpenSource Developer - http://arnaud.quette.free.fr/

Andrew Fenn (andrewfenn) wrote :

This would be a great feature and exactly what I am looking for.

I hope you get around to adding it at some point soon.

Christian Reis (kiko) wrote :

We need to get performance under control -- which probably means, the refactorings done -- before this is fixable, unfortunately.

Changed in rosetta:
importance: High → Medium
Václav Čermák (kingskid) wrote :

Sad to say its more than year and half now....

Vladimer Sichinava (alinux) wrote :

really super useful feature... thanks for working on it!

Christian Reis (kiko) wrote :

On Fri, Sep 07, 2007 at 06:42:00PM -0000, Václav Čermák wrote:
> Sad to say its more than year and half now....

Have you tried using Google to search through Rosetta translations? I'm
curious to know if that works for some portion of the searches you'd
like to do.

jogwi (jogwi) wrote :

We need a search-feature for items that shall be translated - really!

Changed in rosetta:
milestone: 1.1.11 → 1.2.1
schnollk (schnollk) wrote :

Please see for yourself: It seams to work with normal translation projects but doesn't work for e.g. evolution with google site search:

http://www.google.com/search?q=site:https://translations.launchpad.net/ubuntu/gutsy/%2Bsource/update-notifier/%2Bpots/update-notifier/de/%2Btranslate+datentr%C3%A4ger&num=100&ie=utf-8&oe=utf-8

Note the url of the second hit, it ends with &start=10.

Unfortunatelly, it doesn't work for translations.edge.launchpad.net:

http://www.google.com/search?num=100&hl=en&q=site%3Ahttps%3A%2F%2Ftranslations.edge.launchpad.net%2Fubuntu%2Fgutsy%2F%2Bsource%2Fevolution%2F%2Bpots%2Fevolution-2.12%2Fde%2F%2Btranslate&btnG=Search

Nevertheless I'd really apprechiate a feature to be able to search translation strings of a project. The way it is now it's no fun at all to help translate projects and spred them to other languages.

Cheers.

I too really need a search feature to find all the templates containing whatever untranslated strings I stumple upon.
I am currently trying to find the five untranslated strings in kubuntu's log out dialog, which has proven a nightmare of huge proportions.
I'm sorry to say that the current state of Launchpad translation is next to useless for me without a search feature.
Spending whole working days, manually traversing templates is simply not acceptable.
Google's indexing is too slow to help (Gutsy has been out for a month, but is far from fully indexed with google yet).

What is the time frame for a search function?

Best regards

Johnny

+1 for this.

Let's say I am using file roller and want to translate a string in French. I click the "Translate this application" menu and end up in Lauchpad choosing in what language I have in my profile. Then I have the 10 first strings of 243 strings. Filtering this list to only what contain "Loading" would be great!

So... +1 for this :)

Mihkel Tõnnov (v6lur) wrote :

Oh please-please-please :P

Or, in other words, +1 for this.

The method, if you know the PO file, is:
1. download the file from Launchpad.
2. Locate the offending place in the PO file. Note the line number.
3. Execute the command
(
line=1 &&
while read
do [[ "${REPLY:0:2}" == '#:' ]] && echo "${REPLY} ${line}"
let line="${line}"+1
done
)<"${POFILE}" | sort | less
This will give you the messages with line numbers appended, sorted by source file.
4. Use binary search to find the offending line online.
Hint:
The query parameter 'start' is the binary search pointer; the PO line number is not listed online but the target source position is.
Since the view of step 4 is sorted by that (more or less), you can use binary search to look for that entry in the view.
This will give you the line number, and, accordingly, whether you have shot too far or too near (after you compare it with the original line number).
This process is a little cumbersome but it can be automated client-side only with some effort.

Jeroen T. Vermeulen (jtv) wrote :

This needs some research by the database folks, who are currently busy.

Changed in rosetta:
milestone: 1.2.1 → none
dierre (fdr) wrote :

+1 for this...

It is *really* annoying to fix translation if you're not able to search them...

Dennis Schridde (devurandom) wrote :

+1

Máté Őry (orymate) wrote :

This feature would be very useful for terminology changes. That's now a more-than-3-years-old bug.

Dennis Schridde (devurandom) wrote :

It would also be helpful to fix things like https://gna.org/patch/?1047 via Launchpad where a user found spelling mistakes in the translation.

Taavi S. (tuisu) wrote :

There have been numerous times when I've seen a string that's badly translated or not translated at all. But when I eagerly choose the "Translate this application" menu item, I'm usually greeted with 50 to 100 pages of possible strings to look at and sorry, but I'm not going to look them all through to find the string I'm looking for.. there's just no sense in doing that.

My translation efforts are on hold till this feature gets implemented. So all in all, I thought I would say something here to show there's lot of people interested in this feature.

This bug is three years old, I'm sick of this. I'll just get around to removing out all the translations of Specto from rosetta and have translators submit .po files manually, as it is less trouble and I will likely end up with higher quality translations.

Hi guys, as mentioned earlier, this bug can't easily be resolved without changing at least some bits of our infrastructure.

However, we are working in the right direction, and the plan to achieve full functionality is step-by-step:

1. Provide searching through English strings in PO files (i.e. to help with terminology changes)
2. Provide searching through English strings in entire project (eg. Ubuntu, to find which POFile a certain string is in, to help with finding odd untranslated string)
3. Provide searching through translations per PO file (eg. to find misspellings)
4. Provide searching through translations across projects (maybe to check terminology? not sure how useful this would actually be)

1 will definitely happen this cycle (i.e. at the end of April, but only for beta testers, if it works fine for them, then for everybody at the end of May), 2 is likely to happen as well. 3 and 4 require some more agreement about the direction we want to take, however, 3 might be possible pretty soon as well).

schnollk (schnollk) wrote :

I did read the above but just like to comment or drop a pointer to drupal's "interface translation system". You search within admin section of your cms for the string you found untranslated (or any interface string for that matter) and can edit/change the translation right in-place. You can export/import .po files, too.

See, e.g. Localization server project: http://groups.drupal.org/node/5219

We've implemented points 1 and 3 from my previous comment above: searching through PO files (https://blueprints.edge.launchpad.net/rosetta/+spec/search-pofiles).

To find PO files which contain a certain message, you can now use our global search box, so that takes care of the points 2 and 4. We are going to further improve translations-specific search, but if you want to track that, please follow development on https://blueprints.edge.launchpad.net/rosetta/+spec/search

Changed in rosetta:
status: Confirmed → Fix Released
tags: added: iso-testing
tags: removed: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers