Link to LP 3.0 blog post on front page is broken

Bug #435599 reported by Brad Crittenden on 2009-09-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Brad Crittenden

Bug Description

On the front page of launchpad.net is a 'Welcome to Launchpad 3.0' reference to http://blog.launchpad.net/?p=1010 which does not exist.

We need to 1) fix the link and 2) provide some reachability test to ensure this doesn't happen in the future.

Related branches

Brad Crittenden (bac) on 2009-09-24
Changed in launchpad:
status: New → Triaged
importance: Undecided → High
Matthew Revell (matthew.revell) wrote :

The only sure way to fix this is to replace the manually updated blog post links with a feed from the blog itself.

I'd suggest we have a category -- such as "front-page" -- the feed of which is used for the blog posts on LP's front page. This way, only published blog posts would ever show up on the front page, edge, lpnet or wherever. So, only the blog being down would lead to a broken link.

Right now, we manually update the page with selected blog posts. As, often, these blog posts announce features that have not yet been released, the blog posts aren't published when the links appear on edge's front page. So, it becomes difficult to check whether the posts are there or not. Instead, the blog posts are scheduled for publication roughly around the time we estimate that the roll-out of that version will be finished.

So, let's use this bug to track progress of bringing the front page blog posts in from a feed.

Brad Crittenden (bac) wrote :

Actuall Matthew it would be better to open a new bug for the feed issue.

This bug is needed to require a proper landing of the code that was cowboy'ed into production.

Please open a new bug for the feed issue. Thanks.

affects: launchpad → launchpad-registry
Changed in launchpad-registry:
assignee: nobody → Brad Crittenden (bac)
milestone: none → 3.1.10
Brad Crittenden (bac) wrote :

The broken link was landed as r8517. Some type of reachability test still needs to be done so we don't roll-out with broken front page links again.

Changed in launchpad-registry:
status: Triaged → In Progress
Brad Crittenden (bac) wrote :

After discussion with Curtis we have concluded that the solution to this issue is more procedural than one of testing. The root cause of the broken link was the URL changing on the blog side right before roll-out. Even if we had link checkers in place in the days leading to roll-out the problem would not have been averted.

Another issue is one of embargoed blog entries that would not be available until the last minute. Tests on those links would give false positives.

Recommendations:

1) Remove hard links in favor of feeds, as noted previously in this bug.
2) Until then, the Release Manager should personally verify the front page links before roll-out or delegate that task. It should be part of a pre-roll checklist.
3) At the time of the release a blog editor should be available to make blog-side changes if necessary. The Release Manager or delegate should verify the front page upon the completion of the roll-out and be prepared to send a cowboy patch request to quickly resolve the issue. (This procedure happened informally during the 3.0 release.)
4) The links to blogs should use permalink URLs not those based on blog ids that may change. A branch making this change should be released now to remove the bad examples.

Brad Crittenden (bac) wrote :

devel r 9697

Changed in launchpad-registry:
status: In Progress → Fix Committed
Brad Crittenden (bac) on 2009-11-09
Changed in launchpad-registry:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers