Default font should be changed to Vera Sans/Deja-Vu Sans/Verdana

Bug #435356 reported by Mat Tomaszewski on 2009-09-23
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical SSO provider
High
Unassigned
Landscape Server
Medium
Sidnei da Silva
Launchpad Blog WordPress Theme
Low
Unassigned
Launchpad Development Wiki Moin theme
Low
Unassigned
Launchpad Help Wiki Moin theme
Low
Unassigned
Launchpad itself
High
Curtis Hovey
Ubuntu One Servers
Medium
Joshua Blount
Ubuntu Website - OBSOLETE
Undecided
Matthew Nuzum

Bug Description

At the moment users see different fonts depending on the OS used - humanist (Vera Sans) on Ubuntu, neo-grotesque (Arial) on Mac or Windows. The global font definition should be changed to use humanist typeface only.

Related branches

Mat Tomaszewski (mat.t.) on 2009-09-23
Changed in launchpad:
assignee: nobody → Martin Albisetti (beuno)
Martin Albisetti (beuno) on 2009-09-23
affects: launchpad → launchpad-foundations
Changed in ubuntuone-servers:
assignee: nobody → Joshua Blount (jblount)
Changed in launchpad-foundations:
status: New → Triaged
Changed in ubuntuone-servers:
status: New → Triaged
summary: - Default font in LP should be changed to Vera Sans/Deja-Vu Sans/Verdana
+ Default font should be changed to Vera Sans/Deja-Vu Sans/Verdana
Martin Albisetti (beuno) on 2009-09-24
Changed in landscape:
assignee: nobody → Sidnei da Silva (sidnei)
Changed in launchpad-foundations:
assignee: Martin Albisetti (beuno) → Curtis Hovey (sinzui)
Curtis Hovey (sinzui) wrote :

The official CSS property is
    font-family: bitstream vera sans, dejavu sans, verdana, sans-serif;

Which might always be applied to body or *.

Changed in launchpad-foundations:
importance: Undecided → High
milestone: none → 3.1.10
Sidnei da Silva (sidnei) on 2009-09-24
Changed in landscape:
milestone: none → 1.4.0
importance: Undecided → Medium
Sidnei da Silva (sidnei) wrote :

In landscape, we have a couple special headers which have serif fonts. What would be the recommended default for serif? (optionally, should any occurrence of serif in headers just be removed?)

Would this be a sane default?

    font-family: "Bitstream Vera Serif", "Dejavu Serif", "Times New Roman", serif;

Mat Tomaszewski (mat.t.) wrote :

@ Sidnei

Could you please attach some screenshots of pages that include serif font?

Thanks!
m.

Sidnei da Silva (sidnei) wrote :

Here's one. It's probably the only one actually.

Sidnei da Silva wrote:
> Here's one. It's probably the only one actually.
>
> ** Attachment added: "screenshot_048.png"
> http://launchpadlibrarian.net/32357901/screenshot_048.png
>
>

Thanks Sidnei, I think we can safely change it to sans-serif.

m.

Sidnei da Silva (sidnei) on 2009-09-24
tags: added: review
Sidnei da Silva (sidnei) on 2009-09-25
Changed in landscape:
status: New → In Progress
Thomas Herve (therve) wrote :

For landscape:
 * there is still a reference to the old family in the frontpage.css
 * knowledge.css has a "sans-serif" mention which seems unnecessary

+1!

Jamu Kakar (jkakar) wrote :

For Landscape:

[1]

There are a few instances of 'font-family: sans-serif' in the
Salesforce stylesheets. I recommend you update them to use the
style you've used elsewhere:

font-family: "Bitstream Vera Sans", "Lucida Grande", "Verdana", sans-serif;

+1!

tags: removed: review
Sidnei da Silva (sidnei) wrote :

Merged to landscape trunk on r1372.

Changed in landscape:
status: In Progress → Fix Committed
Mat Tomaszewski (mat.t.) on 2009-09-29
Changed in ubuntu-website:
assignee: nobody → Matthew Nuzum (newz)
Joshua Blount (jblount) on 2009-10-13
Changed in ubuntuone-servers:
milestone: none → w27-karmic-final
importance: Undecided → Medium
Joshua Blount (jblount) on 2009-10-13
Changed in ubuntuone-servers:
status: Triaged → Fix Committed
Curtis Hovey (sinzui) on 2009-10-13
Changed in launchpad-foundations:
status: Triaged → In Progress
Joshua Blount (jblount) on 2009-10-14
Changed in ubuntuone-servers:
status: Fix Committed → Fix Released
Mat Tomaszewski (mat.t.) wrote :

The file browser and ajax popups seem not to respect the global setting.

For example:

.yui-pretty-overlay #yui-pretty-overlay-modal {
color:#484848;
font-family:sans-serif;

Curtis Hovey (sinzui) wrote :

Fixed in launchpad devel r9698.

Changed in launchpad-foundations:
status: In Progress → Fix Committed
Martin Albisetti (beuno) wrote :

It should be rolled out on the website as part of a big set of changes.

Changed in ubuntu-website:
status: New → Fix Committed
importance: Undecided → Medium
Matthew Nuzum (newz) on 2009-10-16
Changed in ubuntu-website:
importance: Medium → Undecided
Jamu Kakar (jkakar) on 2009-10-20
tags: added: needs-testing
Curtis Hovey (sinzui) on 2009-10-20
Changed in canonical-identity-provider:
status: New → Confirmed
importance: Undecided → High
Sidnei da Silva (sidnei) on 2009-10-20
tags: removed: needs-testing
Mat Tomaszewski (mat.t.) wrote :

Just to confirm, the font definitions are as per Curtis's comment:

https://bugs.edge.launchpad.net/launchpad-foundations/+bug/435356/comments/1

Please *do not* include any other fonts, like Lucida Grande or similar.

Changed in canonical-identity-provider:
assignee: nobody → Szilveszter Farkas (phanatic)
Jamu Kakar (jkakar) on 2009-11-04
Changed in landscape:
status: Fix Committed → Fix Released

Fixed released in launchpad-project 3.1.10.

Changed in launchpad-foundations:
status: Fix Committed → Fix Released
Changed in canonical-identity-provider:
assignee: Szilveszter Farkas (phanatic) → nobody

This was released in c-i-p with the new codebase.

Changed in canonical-identity-provider:
status: Confirmed → Fix Released
Matthew Nuzum (newz) on 2010-06-08
Changed in ubuntu-website:
status: Fix Committed → Fix Released
Changed in shipit:
assignee: nobody → Anthony Lenton (elachuni)
Changed in shipit:
milestone: none → 10.4.2
status: New → Fix Released
Curtis Hovey (sinzui) wrote :

I am marking the three launchpad wiki/wordpress sites as low because I beleve the font rules we are considering a change the the fonts and all projects will need to be updated.

Changed in launchpad-dev-moin-theme:
status: New → Triaged
importance: Undecided → Low
Changed in launchpad-help-moin-theme:
status: New → Triaged
Changed in launchpad-news-wordpress-theme:
importance: Undecided → Low
Changed in launchpad-help-moin-theme:
importance: Undecided → Low
Changed in launchpad-news-wordpress-theme:
status: New → Triaged
Curtis Hovey (sinzui) wrote :

I marked the remaining websites to wont fix because there is a new bug tracking the switch to the UbuntuBeta and Ubuntu fonts. See bug 620537.

Changed in launchpad-dev-moin-theme:
status: Triaged → Won't Fix
Changed in launchpad-help-moin-theme:
status: Triaged → Won't Fix
Changed in launchpad-news-wordpress-theme:
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers