unhelpful "latest updates" portlet

Bug #430459 reported by Martin Pool on 2009-09-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Medium
Michael Nelson

Bug Description

In <https://edge.launchpad.net/~bzr-beta-ppa/+archive> on edge at the moment (but not on lpnet) I have a portlet saying

Latest updates

    * bzr five days ago
      Failed to build
    * bzr five days ago
      Failed to build
    * bzr five days ago
      Failed to build
    * bzr five days ago
      Failed to build
    * bzr five days ago
      Failed to build

none of these are links and there doesn't seem to be any other way to find out which version failed to build or why, or whether this is still a problem.

I realize this page may just be in transition.

Related branches

Michael Nelson (michael.nelson) wrote :

Hi Martin,

Yes, it is in transition in that we are still planning to have the expander as you suggested (and as in the mockup at https://dev.launchpad.net/VersionThreeDotO/Soyuz/PPAUI) - which will improve the ability to find out more information but I don't think it would address this situation of these failed-to-build entries.

Note, the link directly above to "View package details" (the 'developer' view) shows you all five failed updates with much more information at:
https://edge.launchpad.net/~bzr-beta-ppa/+archive/ppa/+packages

And also, yes, the portlet looks unhelpful in this case because the last five updates all failed - but it is reflecting the situation.

So regarding linking to a failed build - it would be possible, but I'm not sure that it would be helpful currently. As you'll see on the +packages page, one update failed in two archs (amb64 and i386). The portlet is summarising this simply as Failed to build, and could link to the first failed build quite easily, but I think a better solution would be to link to a page that shows all builds for that version of that source package - which we can't currently do, or, even better, link the source package publishing in the PPA - but again, we don't currently have a traversal for individual source packages (they are displayed in the table on the +packages traversal). I think the latter option would be great, but will wait to hear from you and the other soyuz guys.

That said, I thought this portlet was to provide a snapshot of the latest updates/activity primarily for users or potential users of this ppa to gauge the activity (including the drop-down changelog entries you suggested) - developers can always see much more detailed info on the +packages traversal above. So I'm not sure whether this bug itself is a big issue or whether the issue is really that it's non-obvious that this 'developer' information is available via the 'View package details' link.

Julian Edwards (julian-edwards) wrote :

I chatted to Michael and we can add links to the build pages for the failed builds, right there in the portlet.

Changed in soyuz:
assignee: nobody → Michael Nelson (michael.nelson)
importance: Undecided → Medium
milestone: none → 3.0
status: New → Triaged
tags: added: easy ui
Changed in soyuz:
milestone: 3.0 → 3.1.10
tags: added: post-3-ui-cleanup
Changed in soyuz:
status: Triaged → In Progress
Changed in soyuz:
status: In Progress → Fix Committed
Changed in soyuz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers