FileBugViewBase should detect the header HWDB-Submission in data sent by Apport

Bug #424382 reported by Abel Deuring on 2009-09-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Abel Deuring
apport (Ubuntu)
Low
Martin Pitt

Bug Description

We want to automatically link bug reports created by Apport with HWDB submissions.

This is most easily done if Apport includes the header

 HWDB-Submission: submission-key

(or

 HWDB-Submission: submission-key, submission-key...

if the user made more than one HWDB submission on he affected machine)

FileBugViewBase should create a new HWDBSubmissionBug record, once the new bug has been created.

Martin Pitt (pitti) wrote :

Once +storeblob accepts that, I'll change apport to include it. Thanks, Abel!

Changed in apport (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Low
status: New → Triaged
Abel Deuring (adeuring) on 2009-09-07
Changed in malone:
status: Confirmed → In Progress

Fixed in devel r9390.

Changed in malone:
status: In Progress → Fix Committed
Abel Deuring (adeuring) wrote :

Martin,

you can test the new header on staging.launchpad.net once its revision number is >= 8449.

This is a sample MIME message I used for tests:

MIME-Version: 1.0
Content-type: multipart/mixed; boundary=boundary
HWDB-Submission: sample-submission, non-existing-submission-key

--boundary
Content-disposition: inline
Content-type: text/plain; charset=utf-8

This should be added to the description.

--boundary--

Martin Pitt (pitti) wrote :

Thanks Abel, you rock!

Changed in apport (Ubuntu):
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

Hm, I just tried that on staging, with sending this:

Content-Type: multipart/mixed; boundary="===============7747359919282329481=="
MIME-Version: 1.0
HWDB-Submission: 6923ba68f90064b9e2e670997b655a8d
Tags: apport-bug amd64

--===============7747359919282329481==
[...]

I filed staging bugs 437897 and bug 437898 (only valid today), and I neither get any visible reference there in the web ui, and getHWSubmissions() returns an empty collection. Is that still not rolled out to staging perhaps? (it's on r8532)

Martin Pitt (pitti) wrote :

trunk r1613

Changed in apport (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.9.2-0ubuntu1

---------------
apport (1.9.2-0ubuntu1) karmic; urgency=low

  * New upstream bug fix release:
    - apport-cli: Print the URL and ask whether to open a browser. In many
      situations (such as usage on a server through ssh), it's preferable to not
      open the browser on the reporting computer. Thanks to Matt Zimmerman for the
      initial patch! (LP: #286415)
    - general-hooks/generic.py: Collect important glib errors/assertions (which
      should not have private data) from ~/.xsession-errors (LP: #431807)
    - launchpad.py: Link hardware data submission key if it exists. (LP: #424382)
    - apport-cli: Fix crash with non-ASCII characters in prompts.
    - Fix "apport-bug symptomname" to actually work.
    - launchpad.py: Fix crash on invalid credentials file. Thanks to Marco
      Rodrigues for the initial patch! (LP: #414055)
  * man/apport-bug.1: Document APPORT_IGNORE_OBSOLETE_PACKAGES (cherrypicked
    from trunk), and APPORT_STAGING (Ubuntu specific change, since it's a
    launchpad backend specific variable).
  * bin/apport-bug: Ignore -p option when giving two arguments, to keep
    compatibility with current bug filing instructions. (LP: #356755)
  * debian/copyright: Update copyright year and fix GPL link, thanks Marco
    Rodrigues!

 -- Martin Pitt <email address hidden> Fri, 02 Oct 2009 13:25:58 +0200

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
Abel Deuring (adeuring) on 2009-10-30
Changed in malone:
milestone: none → 3.1.10
Abel Deuring (adeuring) on 2009-11-09
Changed in malone:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers