Bugs have no fields to specify package or product versions

Reported by Hervé Cauwelier on 2005-04-17
66
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

I browse through the bugs and check people's comments, but never know which version they are talking about -- it may have been fixed in a later version -- or which system to reproduce their environment.

It will be hell if hoary and breezy bugs are mixed.

Brad Bollenbach (bradb) on 2005-11-02
Changed in malone:
assignee: nobody → bradb
status: New → Accepted
Jeff Bailey (jbailey) wrote :

Jamesh refered to this as "bug infestation" on IRC. Including that here to give vocabulary to the issue.

Brad Bollenbach (bradb) wrote :

kiko, should addressing this problem perhaps be made High priority?

Changed in malone:
assignee: bradb → nobody
Christian Reis (kiko) wrote :

We could do it cheaply by giving the person an entry to include the version field and then adding that to the initial description. I think that gives us most of the benefit without the complexity of the full infestations approach.

On 1-Mar-06, at 2:34 PM, Christian Reis wrote:

> Public bug report changed:
> https://launchpad.net/malone/bugs/424
>
> Comment:
> We could do it cheaply by giving the person an entry to include the
> version field and then adding that to the initial description. I think
> that gives us most of the benefit without the complexity of the full
> infestations approach.

I'm concerned with hacking metadata into the description. The
reporter says "It will be hell if hoary and breezy bugs are mixed",
and they would continue to be mixed if this metadata were hacked into
the description.

This is another possible use case for keywords, the alternatives
involving adding yet another field to BugTask, or a complex
infestations mechanism, which involves even more UI.

Cheers,

--
Brad Bollenbach

I've no idea what "bug infestation" means. It just seems bizarre to me that it's not possible to report the version of a package in a bug report. I notice that people have taken to putting the version [in quare brackets] in the bug title, and I followed this practice in bug 37595. If I follow the links to report a bug in Dapper Drake, I *suspect* I am, in fact, reporting the bug against Dapper Drake, and not the current released version (Breezy Badger) but there's nothing to confirm this to me.

Malone is better than Bugzilla how, exactly?

On Sat, 2006-04-01 at 14:19 +0000, Graeme Hewson wrote:
> I've no idea what "bug infestation" means. It just seems bizarre to me that it's not possible to report the version of a package in a bug report. I notice that people have taken to putting the version [in quare brackets] in the bug title, and I followed this practice in bug 37595. If I follow the links to report a bug in Dapper Drake, I *suspect* I am, in fact, reporting the bug against Dapper Drake, and not the current released version (Breezy Badger) but there's nothing to confirm this to me.

Just to be sure: is there any reason we can't just ask for version and
distribution in the description field? Do you need to filter or query on
specifically these fields?

I suppose we could have the version and distribution in the description field, but it feels like a kludge. It's not only my needs that are important here, and there's no saying what use someone might might want to make of the data in future. I agree with your earlier comment:

> I'm concerned with hacking metadata into the description.

Christian Reis (kiko) on 2006-09-23
description: updated
Diogo Matsubara (matsubara) wrote :

I believe this is fixed with the release targeting feature. It's now possible to track bug status on different distribution releases.

Changed in malone:
status: Confirmed → Fix Released
Matthew Paul Thomas (mpt) wrote :

This bug report is not about release targeting. That a bug first appeared in a particular version of a project is useful to know even if the bug was so minor that it never gets nominated for a release.

Changed in malone:
status: Fix Released → Confirmed
Matthew Paul Thomas (mpt) wrote :

(For further evidence that this is unrelated to nominations, see bug 114766.)

TomParker (launchpad-tevp) wrote :

The Debian bug tracking system mechanism of marking bugs as found/fixed in particular versions (plus smart revision tracking to figure out whether another version should be considered fixed or not depending on whether it descends from a fixed version and so on) would be a nice idea here. You could just work off of Ubuntu package numbers for a simple version, but a smarter version could also note particular revisions of bzr trees (for bonus points, note that a particular Ubuntu package is built from such-and-such a bzr tree, and therefore said package version shares state with the bzr tree).

IMHO this is a major deficit in Launchpad.

Eric Appleman (erappleman) wrote :

I concur and am accordingly request that this bug receive further review.

Colin Watson (cjwatson) wrote :

The "bug infestation" terminology used earlier in the comments on this bug was a term (not invented by me, I hasten to add) used to describe a feature almost identical to that in the Debian bug tracking system. This is no coincidence since I had some brief involvement with the early stages of the Launchpad Bugs design, and I also implemented version tracking in debbugs ...

Bryce Harrington (bryce) wrote :

Ran across this bug via a comment on http://lwn.net/Articles/343085/

A simpler solution to this would be to just include the distro version ('karmic', etc.) as a tag at time of submission. We've been using this approach with xorg bugs, and especially with the new -tag search function helps immensely at sorting through the mess of bugs.

Curtis Hovey (sinzui) on 2010-06-02
Changed in malone:
importance: Medium → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers