package picker lists unpublished (invalid) packages

Bug #42298 reported by Luis Villa
104
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
High
Colin Watson

Bug Description

I just filed a bug against 'kernel-image-2.6'- I picked it out a list of results for 'kernel-image-2.6', since I figured that was most likely to get the most coverage on searches- and got the following note:

"Thank you for your bug report.

Note that the package 'kernel-image-2.6' is not published in Ubuntu; the bug has therefore been targeted to the distribution only."

If the package is not in the distro, and I'm filing a bug against the distro, *don't make it an option to file a bug against it*. The results shouldn't include kernel-image-2.6; it should include whatever is actually in the distro I'm filing against.

The field validator does not match the vocabulary. The vocabulary is doing a lot of work show suggestions that will never be accepted.

Related branches

Revision history for this message
Luis Villa (luis-villa) wrote :

And I note when trying to fix the problem that you already have the ability to do this filtering, so fixing this should be less difficult than I first assumed (though potentially still difficult.)

Changed in malone:
status: New → Triaged
Revision history for this message
Diogo Matsubara (matsubara) wrote : Re: Popup package search lists unpublished packages

Looks like a dupe of bug 202769.

Curtis Hovey (sinzui)
description: updated
summary: - Popup package search lists unpublished packages
+ package picker lists unpublished (invalid) packages
Curtis Hovey (sinzui)
tags: added: package-picker vocabulary
Curtis Hovey (sinzui)
Changed in launchpad:
importance: Medium → High
tags: added: disclosure
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
Changed in launchpad:
assignee: nobody → Steve Kowalik (stevenk)
tags: added: qa-needstesting
Changed in launchpad:
status: Triaged → In Progress
Steve Kowalik (stevenk)
tags: added: qa-untestable
removed: qa-needstesting
Curtis Hovey (sinzui)
tags: added: target-picker
removed: package-picker
Curtis Hovey (sinzui)
Changed in launchpad:
status: In Progress → Fix Released
Curtis Hovey (sinzui)
Changed in launchpad:
assignee: Steve Kowalik (stevenk) → nobody
status: Fix Released → In Progress
tags: removed: qa-untestable
Curtis Hovey (sinzui)
tags: removed: disclosure
Changed in launchpad:
status: In Progress → Triaged
Curtis Hovey (sinzui)
Changed in launchpad:
assignee: nobody → Curtis Hovey (sinzui)
Curtis Hovey (sinzui)
Changed in launchpad:
status: Triaged → In Progress
Curtis Hovey (sinzui)
Changed in launchpad:
status: In Progress → Triaged
Curtis Hovey (sinzui)
Changed in launchpad:
assignee: Curtis Hovey (sinzui) → nobody
Revision history for this message
TJ (tj) wrote :

Eight years later this bug still exists :(

I found it (once again) whilst trying to report a bug against "nvidia-graphics-drivers-340" (currently in the Ubuntu xorg-edgers PPA only).

There is more than just the Package Chooser bug though; I had first added an also-affects "nvidia-graphics-drivers-340 (Ubuntu)" on bug #1247736 which *was* accepted, even though the package doesn't exist.

Colin Watson (cjwatson)
Changed in launchpad:
status: Triaged → In Progress
assignee: nobody → Colin Watson (cjwatson)
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Revision history for this message
Colin Watson (cjwatson) wrote :

My changes aren't quite working yet: the picker doesn't pick up the current value of the distribution drop-down, and Distribution:+filebug (at least) isn't using the new vocabulary yet. However, it's all behind a disabled feature flag, so this doesn't need to block deployments.

tags: added: qa-ok
removed: qa-needstesting
Changed in launchpad:
status: Fix Committed → In Progress
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
Colin Watson (cjwatson)
tags: added: qa-ok
removed: qa-needstesting
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Colin Watson (cjwatson)
tags: added: qa-ok
removed: qa-needstesting
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
Changed in launchpad:
status: In Progress → Fix Committed
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
Colin Watson (cjwatson)
tags: added: qa-ok
removed: qa-needstesting
Revision history for this message
Colin Watson (cjwatson) wrote :
Changed in launchpad:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Colin Watson (cjwatson)
no longer affects: ubuntu
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers