downloads page should include some data about the releases

Bug #419742 reported by Martin Pool on 2009-08-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Brad Crittenden

Bug Description

The downloads page <https://edge.launchpad.net/bzr/+download> tells me nothing about what's actually in the releases.

Could you please include the release notes (ie summary), the release date, the codename, and a link or unfoldy-thing for the changelog? For bonus points, include the number of bugs fixed as in <https://edge.launchpad.net/bzr/2.0>.

(It's true there's a link to the release but there's a lot of noise and blue text on this page and I don't think people see it.)

At the moment, at least for us, you get the series summary text which (see bug 419735) is not very useful.

It may be easy to fix this at the same time as bug 275677 and bug 419735.

Related branches

Changed in launchpad-registry:
assignee: nobody → Guilherme Salgado (salgado)
milestone: none → 3.0
status: New → In Progress
Guilherme Salgado (salgado) wrote :

Releases have a summary (which comes from the milestone associated to them) and the release notes, which I think is more interesting than the summary, but seems to usually be a few paragraphs long. I'll add the release notes right below the release's heading and if it doesn't look good we can either shorten then or use the summary.

As for the changelog, I don't think it's a good idea to include them in the page, even if folded, as it tends to be really long (about 8k just for https://edge.launchpad.net/bzr/1.18/1.18), which would increase the size of the +download page significantly. We also don't have a page showing just the changelog, so I'd have to link to the release's main page, where the changelog is folded at the bottom.

Guilherme Salgado (salgado) wrote :

Release notes have no length limit, just like changelogs (e.g. https://launchpad.net/bzr/1.8/1.8rc1), so we'll have to limit the length that is shown on +download.

Guilherme Salgado (salgado) wrote :

Martin, I'd appreciate if you could have a look at the attached screenshot and tell me if you have any other ideas on how to improve that page further.

2009/8/28 Guilherme Salgado <email address hidden>:
> Martin, I'd appreciate if you could have a look at the attached
> screenshot and tell me if you have any other ideas on how to improve
> that page further.

Thanks Salgado, I think that looks great.

There seems to be a stray comma in the headings " , from the "

I wonder if we could have a link saying "detailed changelog" that goes
to it? At least there used to be a URL that took you straight to it.

I think the "After you've downloaded ..." is a bit of a distraction,
being the first body text on the page but not normally something
people need to see. Is there a standard style that would make it look
more obviously like help or a tip?

Possibly the date should go at the end of the heading line? It looks
a bit crammed in above the files.

Both here and in the single-download page, the release notes are shown
with linebreaks in the places they occurred in the original text.
This seems a bit inconsistent with Launchpad in other places which
tends to treat text as either monospace and unwrapped, or proportional
font with wrapping. For Bazaar, the notes are regular flowed text and
the changelog is a preformatted changelog. But this is probably a
separate bug, because changing it might break people who expect it to
work this way.

--
Martin <http://launchpad.net/~mbp/>

Curtis Hovey (sinzui) on 2009-08-31
Changed in launchpad-registry:
importance: Undecided → High
Curtis Hovey (sinzui) on 2009-09-17
Changed in launchpad-registry:
milestone: 3.0 → 3.1.10
Curtis Hovey (sinzui) on 2009-09-25
tags: added: post-3-ui-cleanup
Curtis Hovey (sinzui) on 2009-10-02
Changed in launchpad-registry:
assignee: Guilherme Salgado (salgado) → nobody
status: In Progress → Triaged
Brad Crittenden (bac) on 2009-10-20
Changed in launchpad-registry:
assignee: nobody → Brad Crittenden (bac)
Brad Crittenden (bac) on 2009-10-21
Changed in launchpad-registry:
status: Triaged → In Progress
Brad Crittenden (bac) wrote :

Martin,

I've inherited this bug from Salgado. I've made some changes to try to address your concerns from comment #4. I hope to have gotten everything except:

* The "After you've downloaded..." bit is still at the top. I've left it because I don't want it to be lost at the bottom of a long page. I think it's better to be a little conspicuous at the top than not seen at the bottom.

* The line breaking of the release notes (and now the change log) is not a result of the original line breaks but do to a CSS decision that limit the width of a paragraph. I think Martin Albisetti picked up this bit from some usability studies that demonstrated very wide text areas are harder for the eye to track. Blame it on Tufte. It's not within the scope of this branch to revisit that decision.

Please have a look at the attached screenshots and let me know if you have additional comments. Unfortunately due to the timing of this branch and your availability I'm probably going to land it as is if I get UI approval. I can do a follow-up branch if you still have issues.

Thanks for doggedly championing this page. It's gotten a lot better due to your input.

Martin Albisetti (beuno) wrote :

On Wed, Oct 21, 2009 at 10:35 PM, Brad Crittenden <email address hidden> wrote:
> * The "After you've downloaded..." bit is still at the top.  I've left
> it because I don't want it to be lost at the bottom of a long page.  I
> think it's better to be a little conspicuous at the top than not seen at
> the bottom.

Could we *just* have the link? "how do I verify a download?"

I'd move the release time to the h2 so it's not right-aligned "2.0
released on 2.x series 19 hours ago".

ui=me, btw

--
Martin

Curtis Hovey (sinzui) wrote :

Are we restricting the size of the release notes? Mine, and the other I tend to read, are a few paragraphs. I do not what to read a novel just to locate the a file to download. My feeling is that since this page is an aggregation, we do not need to show *all* the details of a release...other wise we can dismantle the release and milestone page and just treat downloads ad a blog of releases.

Curtis Hovey (sinzui) wrote :

Fixed in launchapad devel r9763. Bug 461164 trackes whitespace and content size issues.

Changed in launchpad-registry:
status: In Progress → Fix Committed
Martin Pool (mbp) wrote :

I don't know if it's just something broken in my (jaunty firefox) browser but at the moment https://edge.launchpad.net/bzr/+download gives bizarre screen corruption not seen on any other page. I'll file a separate bug for it if I can reproduce it.

I agree that "How do I verify a download" is better. (I kind of wish they would link to help pages not popups, so that the help had a URL etc, but that's separate and probably already been considered.)

The unfold links are OK, though they do make the page look very long.

Martin Pool (mbp) wrote :

Corruption aside, I'm happy to consider this fixed now: you can get some data about the release from the download page. Thanks.

> * The line breaking of the release notes (and now the change log) is not a result of the original line breaks but do to a CSS decision that limit the width of a paragraph.

I don't think that's actually true, because in other places when I've removed the linebreaks it has reflowed them onto longer lines. I'm fine with limiting the width of text areas but that's a different thing.

Martin Pool (mbp) wrote :

I'd prefer if the release notes were shown unfolded (as in brad's screenshot) and only the changelog was a link. I'm not sure if his screenshot is newer or older than what's on edge.

Brad Crittenden (bac) on 2009-11-09
Changed in launchpad-registry:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers