PPA Buildd emails are missing a rationale message

Bug #410893 reported by Māris Fogels on 2009-08-08
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Colin Watson

Bug Description

PPA Buildd system emails should have a rationale message following them, so I can sort the emails using the message text. (I am using Gmail, and Gmail does not support filtering on custom mail headers.)

All other emails have a rationale: Question mails, Bug mails, etc.

Related branches

Māris Fogels (mars) wrote :

This should be a trivial fix:

1) Write a test to verify the rational message's presence
2) Update the buildd mail template

Is anyone willing to sponsor the fix?

Root cause analysis:
  Why doesn't this mail have a rational? Including a rational is part of our design guidelines, but it should be added by the mail notification system templates automatically, shouldn't it?

affects: launchpad → soyuz
Celso Providelo (cprov) wrote :

Right now the buildd-manager sends a single email with multiple recipients, which would cause the email rational to be a little imprecise, eg. "You are receiving this message because you are the owner of this PPA OR the uploader of this source OR the sponsor of this source OR a buildd-administrator".

We should probably change the code to send one message to each possible audience.

Despite of operating in zopeless mode (synchronous email dispatching), I don't think it will result in any major performance issue.

Changed in soyuz:
importance: Undecided → Medium
status: New → Triaged
tags: added: email soyuz-build
Steve Alexander (stevea) wrote :

I was confused by this bug, until I replaced the word "rational" with the word "rationale".

A rational message is one that makes logical sense.

A rationale message is a message that is used to explain the reason behind something.

Julian Edwards (julian-edwards) wrote :

Yes, I was meaning to fix that in the description, thanks for the reminder :)

summary: - PPA Buildd emails are missing a rational message
+ PPA Buildd emails are missing a rationale message
description: updated
Changed in launchpad:
importance: Medium → High
tags: added: notifications
Colin Watson (cjwatson) on 2015-07-13
Changed in launchpad:
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Colin Watson (cjwatson) on 2015-07-17
tags: added: qa-untestable
removed: qa-needstesting
Colin Watson (cjwatson) on 2015-07-30
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers