[Usability] cannot figure out in which package version a fix was released

Bug #406454 reported by Christian Hudon on 2009-07-29
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

Here's the short story behind this bug report. I'm having a problem with my hardy system. As a good user, I search through Launchpad to figure out if my problem was already reported. I think I find a relevant bug report: https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/210468. From the discussion, it looks like it could be my bug. So now I look at the top, and see that a fix was released for hardy. So my next question is, what is the version of the fixed package, so I can compare with the version I'm running now.

I tried a good five minutes, but I couldn't figure out that simple piece of information. For intrepid (where a fix was also released), one can know because the package uploader kindly cut a cut and paste of the package changelog. If that's not there, maybe there's a way to figure out the version which fixed the bug, but I couldn't figure out how.

I'd be really nice if such information could be included in the header at the top. Say: "Fix Released (0.9-hardy4)". Or even "Fixed in [version] 0.9-hardy4".

Thanks for reading.

Micah Gersten (micahg) wrote :

I think this would be a great feature to show which version something is fix released for. There should be an option to set manually or pull it from an automatic close from a changelog. There should also be an option for the fix released version in a Distro before it's actually released so that it can auto close when that version is uploaded. (Should each of those be their own bugs?)

Changed in malone:
status: New → Confirmed
Matthew Paul Thomas (mpt) wrote :

The opposite of this bug is bug 424, about the version(s) in which a bug was found. If either of them are fixed, it may make sense to design them together.

Curtis Hovey (sinzui) on 2010-12-24
Changed in launchpad:
status: Confirmed → Triaged
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers