Deleting the "trunk" series linked to branch messes up the Bazaar repository

Bug #400844 reported by Rob Speer on 2009-07-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Curtis Hovey

Bug Description

I just tried to rearrange branches to make the timeline at http://launchpad.net/divisiui more intuitive. Since all the milestones were on the "prototype" branch and not the "trunk" branch, and I did not want the timeline to branch at all, I made "prototype" the development focus and deleted "trunk".

This had the effect of renaming our repository from ~commonsense/divisiui/trunk to "lp:obsolete-junk/divisiui-trunk-20090625-210501". This is frightening, insulting, and gives the impression that the branch is going to be deleted soon.

Despite having read the pages about series, I do not really understand them, and in particular I cannot understand why deleting a the trunk _series_ would cause the trunk _repository_ to be labeled as "obsolete junk".

For now my co-workers and I can still commit to the branch under the name ~commonsense/divisi/trunk, but on the site it still shows up as "obsolete junk". Do we need to move to a new branch now?

Related branches

Martin Albisetti (beuno) wrote :

This is a very important problem. We should warn the user when an action like delete or rename will make significant changes elsewhere.

affects: launchpad → launchpad-registry
Changed in launchpad-registry:
importance: Undecided → High
status: New → Triaged
Curtis Hovey (sinzui) wrote :

It does warn about this is a serious change. I think the issue is that it was not clear that the UI was and is connected to to real branches. There is nothing wrong with having prototype as the line of development, but if the issues was just about where the milestones were located, they could have been edit to change the series they were on.

Changed in launchpad-registry:
milestone: none → 2.2.9
Curtis Hovey (sinzui) on 2009-07-28
Changed in launchpad-registry:
milestone: 3.0 → 2.2.8
Curtis Hovey (sinzui) on 2009-08-21
Changed in launchpad-registry:
milestone: 2.2.8 → 3.0
Curtis Hovey (sinzui) on 2009-08-31
Changed in launchpad-registry:
assignee: nobody → Curtis Hovey (sinzui)
Curtis Hovey (sinzui) on 2009-09-14
Changed in launchpad-registry:
milestone: 3.0 → 3.1.10
Rob Speer (rspeer) wrote :

This just happened to me again, even though I specifically detached the branch from the series before deleting the series.

The branch "lp:~commonsense/divisiui/trunk" is now, unfortunately, known as "lp:obsolete-junk/divisiui-trunk-20090625-21050". Can someone tell me how to get its legitimate name back?

Curtis Hovey (sinzui) on 2009-09-25
tags: added: confusing-ui
Curtis Hovey (sinzui) on 2009-09-29
summary: - Deleting the "trunk" series messes up the Bazaar repository
+ Deleting the "trunk" series linked to branch messes up the Bazaar
+ repository
Curtis Hovey (sinzui) on 2009-09-30
Changed in launchpad-registry:
status: Triaged → In Progress
Curtis Hovey (sinzui) wrote :

Fixed in launchpad db-devel r8560.

Changed in launchpad-registry:
status: In Progress → Fix Committed

Fixed released in launchpad-project 3.1.10.

Changed in launchpad-registry:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers