Launchpad itself is not translatable in Launchpad

Bug #3896 reported by Petr Tomeš on 2005-11-04
228
This bug affects 36 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

Launchpad cannot be translated.

As we have a translation tool (Rosetta), it makes sense that we let our users to translate the system using it.

Rosetta is part of the Launchpad application, so it's launchpad what should be prepared to be translatable.

We have a plan for this already, but we need to finish other tasks before.

Changed in rosetta:
status: New → Accepted
description: updated
Alex Muntada (alex.muntada) wrote :

As stated in bug 81419, I think that support tracker should be one of the first parts to be able to translate in launchpad.

Just adding this comment here, so there's a reference to the reason why I think this is so important (thanks, Carlos).

Angel Guzman Maeso (shakaran) wrote :

I asked the same thing HERE:
https://answers.edge.launchpad.net/rosetta/+question/18645
I set at the original date HERE:
https://bugs.edge.launchpad.net/launchpad/+bug/3896/comments/0
is 2005-11-04!!!. >>>2007-26-11 MORE THREE YEARS!!

I think that this should be solved NOW and that it is a high priority for greater dissemination.

Thanks

Matthew Paul Thomas (mpt) wrote :

Angel, for it to "be solved NOW" is impossible. Making Launchpad localizable would require a lot of work.

It's not just a programming issue; we'd need to address many other problems at the same time. For example: How would people choose what language they wanted to see Launchpad in? (Would HTTP Accept-Language be enough, or would we need separate UI?) How would projects handle bug reports where the reporter was using a language that none of the developers knew? What would we do with contributions written in a language spoken by none of the Launchpad staff, if someone reported that material as being offensive? (How would we believe the complaints?) Would people be able to host projects where the base language was not English, and use Launchpad Translations to translate that software into English? And so on. I'm not saying that these problems *shouldn't* be solved, just that it would take a while.

Angel Guzman Maeso (shakaran) wrote :

Mattew, not God created the world in a single day.

By this I say, it is not necessary that the whole process of locale is made in a short time, but gradually.

Some answers to your questions may be:

1) How would people choose what language they wanted to see Launchpad in? (Would HTTP Accept-Language be enough, or would we need separate UI?)
>>> Possibly for anonymous users, it is best to choose via HTTP, but such serious for registered users can also configure the profile (GUI).

2)How would projects handle bug reports where the reporter was using a language that none of the developers knew?
>>>When reporting an error, you might be able to report on the languages available to accept the report and notify the user if different from the already has chosen or is HTTP.

3)What would we do with contributions written in a language spoken by none of the Launchpad staff, if someone reported that material as being offensive? (How would we believe the complaints?)
>>>Same as 2), reporting the possible languages that are spoken in the staff and well informed.

4)Would people be able to host projects where the base language was not English, and use Launchpad Translations to translate that software into English?
>>>Same as 2). The user choose.

I think we should start gently with this, or when the project grows more open is a huge gulf as the Tower of Babel.

Francis J. Lacoste (flacoste) wrote :

We likely won't localize the whole of Launchpad ever. For many applications, it doesn't make sense to do so. Code, Blueprints, Bugs are applications that are meant for large open source community of developers. We don't want bug reports, branches or blueprints in languages other than English. Providing a localized UI for those applications would encourage confusion to file content in the native language which is something we don't want.

Translations is different. It could make sense to provide a localized UI for that application, although since all translations always occur from English, we can assume translators are comfortable with the English language.

The Answer Tracker is something we definitively will internationalize. It already supports content in multiple language and only resources are preventing us from completing its localization. See bug 81419 and the linked blueprint to track the status of that endeavour.

As part of that, we'll need to internationalize the login and registration process.

ShipIt might be another candidate for I18N.

Changed in launchpad:
status: Confirmed → Won't Fix
Jean-Philippe Fleury (jpfle) wrote :

> We don't want bug reports, branches or blueprints in languages other than English.

Who are "we"? The Launchpad developers? I really don't understand this attitude. In the page "+new-guided" (1), it's written that "Launchpad is a service for registering and hosting software projects. Service is provided free for open source/free software projects." It's also wriiten: "Hi there! This is a message from the team that develops Launchpad [...]. We're working hard to make sure Launchpad is the best project hosting and registration site out there. We hope you enjoy it here."

So it's not written that we aren't allowed to host non-English projects and that we aren't welcome to this "best project hosting and registration site" if we do so. If you don't want bug reports in languages other than English for your projects, all right. But your projects aren't synonymous with all the projects hosted on Launchpad.

I enjoy coding in my mother tongue and I think I'm more efficient this way. There's a lot of very good free projects that are managed in languages other that English or that are constituted by a significant proportion of non-English speakers. Launchpad should be as welcoming and ergonomic as possible for these projects and for its participants.

There's a need expressed in this bug and its duplicates, in questions, etc. I don't understand why this current report has been marked as "Won't Fix".

(1) https://launchpad.net/projects/+new-guided

Francis J. Lacoste (flacoste) wrote :

Because Launchpad is about collaboration. A bug is not tied to a project but can be linked to multiple projects. Having bug reports in languages other than English prevents the bug from being seen by multiple developers.

So in the parts of Launchpad where the emphasis in collaboration across projects (like bug), it's a Won't Fix.

Jean-Philippe Fleury (jpfle) wrote :

> Having bug reports in languages other than English
> prevents the bug from being seen by multiple developers.

If it was quite true, it would mean that everybody understands English and almost nobody could understand any other languages. I don't believe it.

> Because Launchpad is about collaboration.

I hope Launchpad is also about ergonomics and usability. There are non-English projects hosted on Launchpad and there are also non-English speakers that surf the site. A translated interface would be, beyond doubt, best to get a handle on Launchpad (for many people, and surely even for lots of people who will make reports in English).

Launchpad hosted projects aren't homogeneous and "collaboration" isn't synonymous with "English".

Here are few examples of the usage of other languages than English on Launchpad:

Site de la communauté Ubuntu Francophone
https://launchpad.net/ubuntu-fr-website

Go to the bug tracker of the Ubuntu-fr website. Remark that 99% of all reported bugs are in French, the page title is in French, the announcement is written in French... It's a bit ridiculous in this case that the users aren't able to choose a French interface in their preferences.

Association ubuntu-fr
Liste des membres de l'association ubuntu-fr
https://launchpad.net/~ubuntu-fr-asso

Ubuntu-fr
Cette équipe n'est pas ouverte au public et est réservée aux membres, admins et modérateurs de la plateforme ubuntu-fr.
https://launchpad.net/~ubuntu-fr

I came across this comment:
MERCI de me REPONDRE en FRANCAIS, je ne comprends pas l'anglais.
MERCI de mettre votre site launchpad en français.
https://bugs.launchpad.net/ubuntu/+source/synaptic/+bug/299062

HomeBank. Go to the bug tracker. There's a non-negligible number of bugs reported in French:
https://bugs.launchpad.net/homebank

Linux en Español
Un equipo con un proposito, traducir wikis, manuales y tutoriales a nuestra lengua nativa para facilitarle a todo akel ke no tenga un alto conocimiento de ingles el acceso y la introduccion a este maravilloso S.O.
https://launchpad.net/~spanishlinux

Ubuntu Portugal
Bem vindo à Ubuntu PT
Esta equipa é para todos os utilizadores Portugueses de Ubuntu.
Se estás interessado em participar activamente na comunidade,
frequenta os seguintes meios.
https://launchpad.net/~ubuntu-pt

Ubuntu Portuguese Language Forums
Neste grupo estão todos os membros que participam da equipe de administração/moderação dos fóruns Ubuntu da Língua Portuguesa. Estes fóruns são destinados para interessados em Ubuntu de Angola, Brasil, Cabo Verde, Guiné-Bissau, Macau, Moçambique, Portugal, São Tomé e Príncipe, Timor-Leste e/ou outros que simpatizem com a língua.
https://launchpad.net/~ubuntu-pt-forums

Are you open? Are you selfish? English is not the only language on the world!
If you want to talk with an only language, you should speak in a constructed language, such as Esperanto, a independent language on a nation ...

Nazo (lovesyao) wrote :

Saluton.
Mi amas Tota ideon. Esperanto estas plej bona:-P

In fact, English is de facto standard on the world. But all things should be translatable in Launchpad for preventing dispersing translations.

Kim Ribeiro (kimribeiro) wrote :

I think the reazon "Everybody uses..." isn't what we search to construct a "democratic" Launchpad.
I use esperanto for my contacts out of Brasil and this is, really, an International Language.
I read english, but I'm writing in this language with great dificult...
En la lingvo esperanto mi ne havas tiun malfacilon.

Ner0lph (ner0lph) wrote :

:'(

Translation (en) - Shame: If Launchpad is not translatable, it is useless in the companies of non-English speaking countries and is totally unnecessary. Then they go elsewhere and give up Launchpad. It's disappointing because Launchpad is great ... This will hurt there at Canonical? That is the question.

Original (fr) - Dommage : Si Launchpad n'est pas traduisible, il est inutilisable dans les entreprises des pays non anglophones et leur est totalement inutile. Elles iront voir ailleurs et laisseront tomber Launchpad. C'est décevant car Launchpad est génial... Cela nuira-t-il à Canonical ? Telle est la question.

:'(

Martin Albisetti (beuno) wrote :

The key message here is that if we encourage, say, bug reports in other languages, then we will have dozens of bugs that the developers of Gwibber can't fix because they don't understand them.
So, as a team, we understand that this excludes a certain number of people, as well as making it difficult for others, but the trade-off here is that the majority of the free software world can work together in a language that is already generally understood (as a pretty big example, programming languages themselves use English words).
We would absolutely love to be able to appeal to even more users and make them feel comfortable with the interface, but it is a requirement that the language doesn't become a barrier for everyone else at the expense of a few. If we manage to, say, get live translations with good quality, this may be possible in the future.

To be clear, most of the Launchpad developers aren't native English speakers, so this not a personal preference as much as it is a strategic decision to ensure collaboration as smoothly as possible.

Walker Gusmão (walkergl) wrote :

I am from Brazil, and my english is poor.

The translation of launchpad is a great fix. Launchpad TOOL (not content) can be translated. Local projects can be in the language of where the project is maintained, used and disseminated, no problems! But Big Projects, with global reach, NEED to be in english language (the content, not TOOL).

Ner0lph (ner0lph) wrote :

Martin : I didn't talk of the content, of course, but the tool. And I understand what you mean.
Walker : Or esperanto for the content. ;-P (I do not speak the language but I find it amazing.)

AJenbo (ajenbo) wrote :

Having the Rosetta UI translated would be a big help for translators, it would have have them think primarily in the language that they where translating for instead of English.

Sense Egbert Hofstede (sense) wrote :

By saying that it is not useful to translate certain parts of Launchpad you deny people who are not so proficient in English access to this project management website. An all English website puts people off, even if they can speak English.

When your English isn't very good it costs a lot of energy to read and write it. When you'd only have to write it, but can read the interface in your native language, things are much easier.

Also see <http://sensehofstede.nl/realise-native-english-speakers-are-privileged> for more arguments why the use of English can be a hindrance to contributions.

On top of that the LoCo Council seems to be encouraging Ubuntu LoCo teams to use Launchpad as much as possible. That does mean that the English-speaking LoCo teams have a huge advantage since they have this great tool at their disposition. For non-English LoCo teams, however, it is not that easy to use Launchpad. Many people in the LoCo teams are not that proficient in English at all.
One of the most important reasons why we're using Launchpad only very little in Ubuntu NL is because of the fact that it is fully English. Not everyone can use that language or wants to use it.

By keeping the code and bugs section English you also make it harder for a certain group of people to contribute (code) to the projects on Launchpad. Say someone can read some English but has trouble writing a lot of it. That means that the person can still perfectly contribute code. However, he'd have to use Launchpad in English, which is hard for him.

Native English speakers, please realise that not everyone finds using English as easy as you.

yugurten (yugurten) wrote :

I translate in Kabyle language , and there isn't a team lanchpad ubuntu-kab, I am a native of that language, I speak and I write this language , I was blocked !! what I will do ?

thank you

Robert Collins (lifeless) wrote :

Reopening this because doing (some) i18n and l10n is desired by stakeholders.

Changed in launchpad:
status: Won't Fix → Triaged
V字龍(Vdragon) (vdragon) wrote :

#14,
How about allow non-English bug report with "translatable bug report content" as well?
Make the non-fully-translated report to be filtered may cause less irritance... I guess.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions