Disabled PPA still blocks users from renaming their accounts

Bug #386167 reported by Steve McInerney on 2009-06-12
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Julian Edwards

Bug Description

ref: https://answers.edge.launchpad.net/launchpad/+question/73273

User was unable to rename their account, even with their PPA administratively disabled.
An admin (ie me) was able to do the rename via the UI.

Would expect that with a disabled PPA, the user could also rename their account.

Related branches

affects: launchpad → launchpad-registry
Curtis Hovey (sinzui) wrote :

Soyuz controls that restriction.

affects: launchpad-registry → soyuz
Julian Edwards (julian-edwards) wrote :

The disabled status doesn't really make much difference, unfortunately., because we would still need to clean up the repo area. If the PPA has no published items, then we can simply delete the repo. If it does still have things published, then we need to rename it.

Ideally, we also need a "nuke PPA" option that will set all the publications to DELETED and remove all traces of the repo.

Another option is that we de-couple the user's name from their PPA URL but we need to be careful about that as the URL then becomes non-determinate.

Changed in soyuz:
importance: Undecided → Low
status: New → Triaged
Tom Haddon (mthaddon) wrote :

We're getting an increasing number of requests to rename accounts with PPAs, and running raw SQL is always a bad idea. Increasing importance.

Changed in soyuz:
importance: Low → High
Julian Edwards (julian-edwards) wrote :

If you need to rename an account again, please do not get the person to make a new account and merge. This completely orphans the PPA and requires more SQL to clean it up.

Julian Edwards (julian-edwards) wrote :

Now that the deletion of the PPA repos is released, we can enable account renaming if a person has no active PPAs.

Changed in soyuz:
assignee: nobody → Julian Edwards (julian-edwards)
milestone: none → 10.05
Julian Edwards (julian-edwards) wrote :

A fix will land tomorrow that will allow account renaming with:
1) people with PPAs that have never published packages
2) people who have deleted all their PPAs

Changed in soyuz:
status: Triaged → In Progress
tags: added: ppa
Changed in soyuz:
status: In Progress → Fix Committed
tags: added: qa-needstesting
Dan Bishop (danbishop) wrote :

I've deleted my ppas and renamed my account successfully... however now when I try to check out my branches in bzr I get:

dan@dan-laptop:~$ bzr branch lp:lex
bzr: ERROR: Not a branch: "bzr+ssh://bazaar.launchpad.net/~danbishopuk/lex/trunk/".

dan@dan-laptop:~$ bzr branch lp:~danbishop/lex/trunk
bzr: ERROR: Not a branch: "bzr+ssh://bazaar.launchpad.net/~danbishopuk/lex/trunk/".

danbishopuk being my old username

William Grant (wgrant) wrote :

Dan, looking at .bzr/branch/branch.conf in that branch we can see "stacked_on_location = /~danbishopuk/lex/trunk" -- it's stacked on the old location for the *same* branch! Did you push this branch up alongside another trunk branch, then rename this new branch to trunk? If so, this is bug #377519.

To fix this, you'll need to remove the stacked_on_location from branch.conf. You can use any SFTP tool (Nautilus or lftp, for example), or the bzr hitchhiker plugin.

Then everything should work again.

Dan Bishop (danbishop) wrote :

That would indeed seem to be the problem, however, I can't work out what settings I need to connect via sftp and fix this... I just keep being told that the folder does not exist.

Please could you help me with the details? Server, folder, username...

Presumably server=bazaar.launchpad.net and username danbishop?

William Grant (wgrant) wrote :

You'll need to poke at sftp://bazaar.launchpad.net/~danbishop/lex/trunk/.bzr/branch/branch.conf. You may have to change into /~danbishop/lex/trunk directly -- attempting to look at / could fail.

Dan Bishop (danbishop) wrote :

Thanks. Turns out it was nautilus causing the issues. used filezilla and everything worked fine :)

Luke J Militello (kilahurtz) wrote :

Is there a way yet to purge all old "grayed out" PPA's from your personal page yet?

On Thursday 13 May 2010 17:34:01 you wrote:
> Is there a way yet to purge all old "grayed out" PPA's from your
> personal page yet?

No, this can't be done yet.

tags: added: qa-ok
removed: qa-needstesting

Despite the fact that I only have one - empty and "deleted" - ppa, I
keep getting the following message (on edge):
"This user has an active PPA with packages published and may not be
renamed."

Could someone look into that, please? (username "~debian-io")

Tom Haddon (mthaddon) on 2010-05-28
tags: added: canonical-losa-lp

I have an empty and deleted PPA which is shown in grey. Yet I caanot change my name. The following is shown:

 mrinal-kant

This user has a PPA and may not be renamed.

Curtis Hovey (sinzui) on 2010-06-02
Changed in soyuz:
status: Fix Committed → Fix Released
Fionn (fbe) wrote :

Would someone please enlighten me what sort of "fix" has been released
here, because renaming is still NOT working for me, as described above.

Thank you! :-)

Something has regressed in the deletion, I'm re-opening this to examine the situation. Thanks for letting me know.

Changed in soyuz:
status: Fix Released → In Progress
milestone: 10.05 → 10.06

This is now fixed, sorry for the hassle everyone. Any PPAs marked as deleted that you were having trouble with are really now deleted.

Changed in soyuz:
status: In Progress → Fix Released
tags: added: qa-needstesting
removed: qa-ok
tags: added: qa-ok
removed: qa-needstesting
Fionn (fbe) wrote :

Works for me now. Many thanks!

Jamal Fanaian (jamalta) wrote :

Does it take a while for deleting PPAs to enable the ability to modify my account's username? I tried deleting the PPAs that existed in my account, and now they both are grayed out, but I still cannot change my username.

Yes, it can take up to 10 minutes.

Luke J Militello (kilahurtz) wrote :

Will there be an option to purge all old greyed out PPA's in the future?

On Monday 21 June 2010 15:16:57 Luke J Militello wrote:
> Will there be an option to purge all old greyed out PPA's in the future?

There's no immediate plans to fix that, but we're happy to take patches if
someone wants to tackle it.

hello, i have already deleted all of my PPA, and all of them are turning to grey.
but im still cant change my username.

Jiří Janoušek (fenryxo) wrote :

Is this bug really fixed? I have my PPAs deleted for days and I still can't rename my account.

Melroy vd Berg (openlaptop) wrote :

I also have the same problem, hello? I disabled all my PPA's I still says 'This person has an active PPA with packages published and may not be renamed.'.

William Grant (wgrant) wrote :

You need to delete the PPAs, not just disable them. You'll see a "Delete PPA" link on the right sidebar of each PPA's page.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers