AssertionError: still have data in FSETSTAT:

Bug #376279 reported by Jonathan Lange on 2009-05-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Michael Hudson-Doyle

Bug Description

OOPS-1229SMPSSH5 reports:
  1 AssertionError: still have data in FSETSTAT: 'J\\x0b6\\x9cJ\\x0b6\\x9c'

No idea what's causing this, could be a Twisted bug or a buggy sftp client.

Related branches

Michael Hudson-Doyle (mwhudson) wrote :

Whatever the cause, this certainly happens and causes oopses, so we should at least think about fixing it.

Changed in launchpad-code:
status: Incomplete → Triaged
importance: Undecided → High
Michael Hudson-Doyle (mwhudson) wrote :

This was bug http://twistedmatrix.com/trac/ticket/2902, which I fixed over a year ago. Should cherry pick into our twisted branch I guess.

Changed in launchpad-code:
status: Triaged → In Progress
Changed in launchpad-code:
milestone: none → 3.1.10
assignee: nobody → Michael Hudson (mwhudson)
Changed in launchpad-code:
status: In Progress → Fix Committed
Changed in launchpad-code:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.