People search does not work with cyrillic characters

Bug #366173 reported by Arne Goetje on 2009-04-24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Launchpad itself

Bug Description

If a launchpad user uses Cyrillic letters in his user name the people search function won't find him.

I tried to find "Данило Шеган" without success (user id: danilo).

Probably other non-Latin characters have the same fate and are ignored by the search application.

And searching for "Björn" errors out with OOPS-1213EA327.

affects: launchpad → launchpad-registry
Changed in launchpad-registry:
status: New → Triaged

Ursula Junque wrote:
> *** This bug is a duplicate of bug 251569 ***
> ** This bug has been marked a duplicate of bug 251569
> UnicodeEncodeError/UnicodeDecodeError when browser submits non-utf-8 data

Erm... I am running a UTF-8 locale like all the Ubuntu installations.
Therefor the browser submits UTF-8 data. So I don't think these bugs are

Considering the search Arne tried didn't OOPS at all, this is neither a duplicate of bug 251569, nor of bug 44919.

The search Arne tried simply returns no results. It seems like a bug to me, I can reproduce it.

The OOPS Danilo mentioned is a separate issue, and is indeed bug 251569.

summary: - People search does not work with cyrillic charcaters
+ People search does not work with cyrillic characters
Curtis Hovey (sinzui) wrote :

I think we need to re-invent searching for and presenting people.

Changed in launchpad-registry:
importance: Undecided → Low
Curtis Hovey (sinzui) on 2010-12-04
tags: added: search
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers