Launchpad should allow reply editing and/or removal by user (without administrative intervention) for various reasons

Bug #358017 reported by Andrea Francia on 2009-04-08
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Unassigned
launchpad-integration
Undecided
Unassigned
launchpad-integration (Ubuntu)
Low
Unassigned

Bug Description

I can edit the question but I can't edit the answer. Why you can edit the question and not the answers or replies?

What if I'm doing e-shopping having also https://answers.launchpad.net/ open. I'm copying and pasting my credit card number in the e-shop form, then suddenly my cat jump on my keyboard and the my credit card number is pasted in a answers.launchpad.net and the form is submmitted?

What if I'm reporting a long log file excerpt with personal informations (like MAC addresses or passwords) and after removing almost all sensible informations and submitting the reply I realized that I missed the remove a single important personal information?

Websites like stackoverflow.com allow you delete a reply for any reason without delay. Other sites wait some minutes before copying replies across the network (through mails) for decrease the information leak in case that the user changed his/her mind and decide to remove his/her post.

Some jurisdiction like the Italian law about privacy says that the holder of personal data should be able to obtain the removal of any personal data without any unjustified delay (Dlgs 196/2003 Art. 7 and Art.8) http://www.camera.it/parlam/leggi/deleghe/Testi/03196dl.htm

The law speaks about the removal of any data which is personal, not only data *too* personal.

Maybe this something that it's true to all the EU. I'm not a lawyer.
From http://en.wikipedia.org/wiki/Information_privacy_law :
----begin-of-wikipedia-excerpt----
The European Directive on Protection of Personal Data, released on July 25, 1995 was an attempt to unify the laws on data protection within the European Community. As a result, customers of international organizations such as Amazon and eBay in the EU have the ability to review and delete information, while Americans do not.
----end-of-wikipedia-excerpt----

Isn't the law of country of the user that matters when a service is used across countries boundaries?

Update:

Based on responses:
We also think think this change this affect not only Launchpad Answers, but also other systems, such as Launchpad Bugs. It would be handy to be able to edit and/or delete your *response* within a specific time-frame of posting in case of whatever response for whatever reason.

Andrea Francia (andrea-francia) wrote :

This would be a bug report about the launchpad.net website not about Ubuntu. I don't know how to change the "Affects" field.

Andrea Francia (andrea-francia) wrote :

It's about answer not Ubuntu

Changed in ubuntu:
status: New → Invalid
Tom (tom6) wrote :

It's the same as changing the status. Something weird happened when i tried changing the "Affects" thing and it wouldn't let me put it in the right place but then somehow it's got both places showing lol. Anyway, at least it seems to be going to the right place (and where-ever i sent it too!)

Apols, thanks, good luck and regards from
Tom :)

affects: ubuntu → launchpad-integration (Ubuntu)
Changed in launchpad-integration (Ubuntu):
status: Invalid → New
Sebastien Bacher (seb128) wrote :

the issue is not a bug in the launchpad-integration ubuntu code which adds menu entries to software

Changed in launchpad-integration (Ubuntu):
importance: Undecided → Low
status: New → Invalid
Tom (tom6) wrote :

Sorry, thanks for fixing that Sebastien :)

Bhavani Shankar (bhavi) wrote :

I think its a real valid concern, affects me too :) setting the status to confirmed...

Changed in launchpad-answers:
status: New → Confirmed
Tom (tom6) wrote :

I think there is a concern that if everyone can change any posting they've made in a thread then the answers that follow may not make or be completely wrong or even damage someone's system if they are looking through past questions to help solve their current problem. Even a subtle change in a nuance in a question might radically the answers received.

I think that once people realise that it's a public forum and that their postings cannot be altered it discourages flaming attacks and rudeness hence encouraging a more family-friendly environment.

On the other hand there are clearly likely to be times when it would be good to have a responsible moderator able to edit out certain things.

I've not seen any of the possible instances occur in all the time i have spent in here and it's been my experience that moderated forums tend to be quite unpleasant. I think we should expect the level of maturity and caution that we currently have and avoid falling into the traps that this bug could lead us.

"The road to hell is paved with good intentions"
Regards from
Tom :)

Martin Pool (mbp) wrote :

It seems like this is not even specific to answers, but also bugs and other places: you want a way for people to remove all data they posted, which is not Launchpad's approach at present.

In practice, you can contact an admin through the link at the bottom of any page and they will remove it. So the question is just whether you should be able to do it immediately without admin intervention.

Craig Huffstetler (xq) wrote :

I agree, it is a valid concern around certain sections of Launchpad.

A "timer" could be initiated for submitted content, say 1 minute. I've seen this on other sites (AJAX-y) where you are allowed to edit your content or even delete it for X amount of time after you have submitted it.

This would be a nice feature to have in Bugs and in Answers. I am not very familiar with the other Launchpad Foundation systems, and their interworkings, but I at least know they do apply to Launchpad Bug Comments and Launchpad Answers ("Comments," "Answers," "Information Requests").

Tom (tom6) wrote :

A time factor addresses my concerns. Often it's just after making a post that you immediately realise an error worth correcting, or something that should be usefully added (or deleted).

Nice one Craig :)
Regards all, from
Tom :)

Yes tom +1 from me :)

On Thu, Apr 9, 2009 at 11:29 PM, Tom <email address hidden> wrote:

> A time factor addresses my concerns. Often it's just after making a
> post that you immediately realise an error worth correcting, or
> something that should be usefully added (or deleted).
>
> Nice one Craig :)
> Regards all, from
> Tom :)
>
> --
> Answer doesn't allow you to remove replies
> https://bugs.launchpad.net/bugs/358017
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Bhavani Shankar.R
https://launchpad.net/~bhavi, a proud ubuntu community member.
What matters in life is application of mind!,
It makes great sense to have some common sense..!

It's disappointing to see this has been marked a duplicate of an old dead bug-report when so many people have shown an interest in this and suggested much more advanced ideas.

Perhaps in some cases it'd be more relevant to mark the older empty one as a duplicate of the one that has a wealth of ideas in it?

Regards to all from
Tom :)

Craig Huffstetler (xq) wrote :

I agree. I understand how the "duplicate status" works, but I think this bug is "where it's at." This is where a) the ideas are, b) the Answers team member's are subscribed (initially, at least) and c) the comments are.

I think this is where the primary discussion should take place. The other bugs should be marked as duplicates.

Craig Huffstetler (xq) wrote :

I guess we can't add what we think it affects anymore either (I.E. add Launchpad Foundations or Launchpad Bugs) since it is a duplicate.

I think Bug Control should revert the duplicate status as described above by myself and Tom.

Sincerely,

Craig

Craig Huffstetler (xq) on 2009-04-14
description: updated
tags: added: launchpad
summary: - Answer doesn't allow you to remove replies
+ Launchpad should allow reply editing and/or removal by user (without
+ administrative intervention) for various reasons
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in launchpad:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions