launchpad mailing list archive UI problems

Bug #357775 reported by Karl Fogel on 2009-04-08
4
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Karl Fogel

Bug Description

This is a bit of a grab-bag issue about our current mailing list archive user experience.

We regressed in UI when we switched from the pipermail archives at lists.ubuntu.com to the mhonarc-based system in lists.launchpad.net. See here for an example of what the new interface looks like:

   https://lists.launchpad.net/launchpad-users/

Some problems with it:

  - the name of the mailing list is not shown on its archive index pages
  - indexes are single-page, not multi-page: a 100,000 msg list means a page w/ 100,000 items :-).
  - indexes list messages earliest-first, instead of latest-first
  - indexes do not show the date next to the message
  - text is black-on-neutral-browser-default, instead of black-on-white like the rest of LP

These regressions aren't really MHonArc's fault; we just need to make better use of its built-in customization ability, to do multipage indexes, etc. It's almost done on this branch-in-progress: https://code.edge.launchpad.net/~kfogel/launchpad/ml-archiver-ui; thanks much to barry for answering lots of Launchpad questions for that branch.

Secondly, aside from the above regressions, our archives have always had some problems:

   - archives not searchable (could at least outsource to $Google via a site-bound search form)
   - UI look and feel not similar to the rest of Launchpad
   - message URLs not predictable (see http://wiki.list.org/display/DEV/Stable+URLs)

Note that switching to MHonArc did bring some advantages. We now have stable message URLs (even if not predictable ones). That is, if you regenerate an archive from the source mails, you'll get the same message URLs again. Obviously, that property comes along with predictable URLs anyway, so if we get that feature, we don't have to do anything extra to get stable URLs.

Also, when a thread is split across different months (well, across different pages of a multi-page index), the archiver should do something sane with that, instead of pretending that there's no connection. IIRC, pipermail does not indicate any connectedness. The dangling message does not even have a "next in thread" / "prev in thread" link (see Jason Earl's message at the top of https://lists.ubuntu.com/archives/bazaar/2009q2/thread.html#55942 for an example). MHonArc at least gives an indication that the thread extends backward or forward to another page, although the UI for that connectedness could be better.

Anyway, all the above is a rough description of what a truly pleasant archiving system would look like. It would be nice if we got closer to that, whether by improving Pipermail or MHonArc or writing something from scratch. (Although MHonArc is in Perl, while Pipermail and Launchpad are both in Python, MHonArc turns out to be quite extensible, so it's not automatically the wrong choice.)

Karl Fogel (kfogel) on 2009-04-08
description: updated
description: updated
description: updated
Revision history for this message
Karl Fogel (kfogel) wrote :

Regarding the low-hanging fruit: it's working now, much thanks to Barry and to Steve McInerney in IRC tonight. I'm attaching a screenshot of what the new UI looks like; there's only one message in the data right now, so you'll have to use some imagination. Further improvement: same white-background-and-lp-logo stylations should be applied to the message page (the screenshot doesn't show it, but that isn't done yet).

Revision history for this message
Karl Fogel (kfogel) wrote :

Hunh. Something buggy about that GIMP screenshots, it seems. Let's try again.

Revision history for this message
Barry Warsaw (barry) wrote :

I know where you're going with this, and a big +1 from me. When you're ready, you should do a proper merge proposal. Assign the code review to me and the ui review to Martin.

Revision history for this message
Karl Fogel (kfogel) wrote :

Okay, the individual messages are now stylated too, as of r8113 on https://code.edge.launchpad.net/~kfogel/launchpad/ml-archiver-ui .

Revision history for this message
Karl Fogel (kfogel) wrote :

Hmm, sigh, once again semi-simultaneous comments are merged instead of colliding :-). Barry, I didn't see your comment above when I wrote mine. I just want to run EC2 tests before doing the merge proposal; that's the only thing it's waiting on now.

Revision history for this message
Karl Fogel (kfogel) wrote :
Revision history for this message
Karl Fogel (kfogel) wrote :
Revision history for this message
Karl Fogel (kfogel) wrote :

I've filed bug #397673 about needing search.

affects: launchpad-foundations → launchpad-registry
tags: added: mailing-lists
Curtis Hovey (sinzui) on 2009-07-15
Changed in launchpad-registry:
status: New → Triaged
importance: Undecided → Low
tags: added: ml-archive-sucks
Karl Fogel (kfogel) on 2009-07-15
Changed in launchpad-registry:
status: Triaged → Fix Committed
Curtis Hovey (sinzui) on 2009-07-15
Changed in launchpad-registry:
assignee: nobody → Karl Fogel (kfogel)
milestone: none → 2.2.7
Curtis Hovey (sinzui) on 2009-07-23
Changed in launchpad-registry:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers