Give Ubuntu translation coordinators full admin access to Ubuntu templates.

Bug #353706 reported by Jeroen T. Vermeulen
8
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
High
Jeroen T. Vermeulen

Bug Description

This is a follow-up to bug 341081: allowing the owners of the Ubuntu translation group to approve Ubuntu translation uploads.

A pleasant side effect of that branch was to extend admin rights for Ubuntu templates to the translation group's owners, but Adi reports still not being able to access the +edit and +admin pages.

Revision history for this message
Adi Roiban (adiroiban) wrote :

I can access +admin but for example I can not change the template priority.

I don't have access to +edit or +upload.

Revision history for this message
Jeroen T. Vermeulen (jtv) wrote :

Filed the +upload matter separately as bug 353730.

summary: - Let Ubuntu translation coordinators access Ubuntu templates' edit/admin
- pages.
+ Give Ubuntu translation coordinators full admin access to Ubuntu
+ templates.
Revision history for this message
Jeroen T. Vermeulen (jtv) wrote :

On the admin page, all fields show up normally, but changing certain fields triggers a permissions error ("Sorry, you don't have permission to access this page.")

However, Adi can change template name, domain, source package, language-pack switch, and the "allow translations" switch.

Revision history for this message
Jeroen T. Vermeulen (jtv) wrote :

The cause of the problem is that UTCs got Admin rights on the templates, as needed to resolve bug 341081, but not Edit rights. Easy enough to fix.

Revision history for this message
Jeroen T. Vermeulen (jtv) wrote :

Fixed in RF 8154

Changed in rosetta:
importance: Undecided → High
milestone: none → 2.2.4
status: New → Fix Committed
assignee: nobody → jtv
Revision history for this message
Adi Roiban (adiroiban) wrote :

I found an interesting behaviour.

Even thou I can upload an archive containing .po files for a template, I can not upload individial .po files for a langauge.

Also I can not change the translations using the web interface.

I fixing some small errors in ubuntu-docs, it rather than uploading an whole archive just for fixing 2 letter, I prefer to use the web interface.

Revision history for this message
Данило Шеган (danilo) wrote :

The difference is that when you upload a tarball, that's a "published" upload, and that's the only thing you can do now. You are trying to do LP edits, and you still don't have the privilege. We might want to extend those privileges as well, but it's something for us to talk about later.

Changed in rosetta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers