Missing Priority headers in universe Sources.gz

Bug #3537 reported by Matt Zimmerman on 2005-10-24
4
Affects Status Importance Assigned to Milestone
Launchpad itself
Medium
Unassigned

Bug Description

For example:

@@ -115261,7 +114977,6 @@
 Package: zorp
 Binary: zorp-doc, libzorp2-dev, zorp-modules, zorp, libzorp2
 Version: 2.0.9-2
-Priority: optional
 Section: universe/net
 Maintainer: SZALAY Attila <email address hidden>
 Build-Depends: python-dev (>= 1.5.2), python-extclass (>=1.2-1), libssl-dev (>=0.9.6c-1), libglib2.0-dev, libzorpll-dev (>= 2.0.26.18), debhelper (>=4.1.67), libcap-dev, libtool, g++, autoconf, automake

seen in dists/warty/universe/source/Sources.gz

Matt Zimmerman (mdz) on 2005-10-29
Changed in launchpad-publisher:
assignee: nobody → dsilvers
Christian Reis (kiko) wrote :

I hate to say this, but the SourcePackageRelease table doesn't even have a Priority field. Guess this needs to be added to the database and to Gina (and support added to this for the uploader, right?)

Christian Reis (kiko) wrote :

From inspection, we don't seem to store Standards-Version headers either. Should we? It seems to vary between packages -- i.e. a52dec and aalib in breezy/main.

Christian Reis (kiko) wrote :

We've decided that Priority headers are not strictly required in Sources files. There should be no tool that actually uses them.

Changed in launchpad-publisher:
assignee: dsilvers → nobody
status: Unconfirmed → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers