In Internet Explorer 8, bug report pages have stray "Continue" button

Bug #345777 reported by Fredrik "DXter" Jonsson on 2009-03-20
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Edwin Grubbs

Bug Description

When viewed in Internet Explorer 8 (using the default rendering mode), bug report pages have a "Continue" button floating in the middle.

Screenshot: http://launchpadlibrarian.net/24275711/launchpad_native.jpg

Related branches

Matthew Paul Thomas (mpt) wrote :

Hi Fredrik. Launchpad is indeed designed to be browser-independent, and it's important for it to work well on recent versions of Internet Explorer. Can you be more specific about the problem you see? The best way to describe it would be to attach a screenshot of the problem, give the URL where it happens, and say whether it happens all the time or just sometimes.

Changed in launchpad:
status: New → Incomplete
Fredrik "DXter" Jonsson (dxter) wrote :

Here is some screenshots of Launchpad in action running on native IE8 vs compatibility mode IE8. I also noted now that when running emulated mode, the subscribers field never gets populated, however it does when it is running native IE8 mode. I find this very strange if you ask me.

Matthew Paul Thomas (mpt) wrote :

So the only problem with the default, standard view is that a "Continue" button appears in the middle of the page. Is that right? I have no idea where that button is coming from, because the word "Continue" isn't anywhere in the HTML for this page (or at least, wasn't until I wrote it in this comment).

I don't think it's reasonable for Launchpad to try to work around bugs that happen only in Compatibility View. If the problem with the subscribers not loading actually happens in IE7 itself, certainly we should try to fix that. But if it happens only in IE8's emulation of IE7, probably that can be fixed only by Microsoft in IE8.

Changed in launchpad:
status: Incomplete → Confirmed
Fredrik "DXter" Jonsson (dxter) wrote :

The problem is not only the "Continue" button. I also find many links are non responsive when I am using IE8. You might understand that it is hard to get a screenshot of that. :)

Matthew Paul Thomas (mpt) wrote :

Ok, please report a bug about each type of link that doesn't work. For example, if none of the links in a particular area of the page work, report one bug about that. If the "Add a comment" link doesn't work on any bug report page, report one bug about that, and so on. Meanwhile, we'll use this bug report solely for the stray "Continue" button.

description: updated
summary: - Launchpad is very instable with Internet Explorer 8
+ In Internet Explorer 8, bug report pages have stray "Continue" button
Marco Rodrigues (gothicx) wrote :

I also have this problem. Screenshot is attached.

poy (poy) wrote :

same here, and as Marco's screen-shot shows, this is not only on bug report pages but on other pages too (blueprints, translations, and even on the <https://launchpad.net/> home page).

the button doesn't show up immediately along with the rest of the page, but a little while after the page has been loaded, so it must be related to some dynamically loaded elements.

note that on the home page, the button shows up only once it has been hovered by the mouse, and that i can't see it when switching to "Compatiblity View" mode. (but as stated above the rest of Launchpad isn't great under compat mode so that is not an option.)

poy (poy) wrote :

i opened the home page inside the "Developer Tools" thingie that IE 8 has and found that the button is in the DOM tree as:
<input id="help-close-btn" type="button" value="Continue">
under the "invisible", "help-footer" and "help-close" blocks.

for details, i'm attaching a screen-shot (couldn't find out how to copy as text from their interface...).

Jean.c.h (slug71) wrote :

Confirmed. I have this too. Does nothing when you click on it.

poy (poy) wrote :

simple test case of a button with "visibility: inherit" inside a block with "visibility: hidden"; the button is hidden on every browser out there except IE 8.
the bug is reported here: <https://connect.microsoft.com/IE/feedback/ViewFeedback.aspx?FeedbackID=442805>.

if you are willing to work around what seems to be a defect in IE 8, then a possibility would be to remove that "visibility: inherit" style.

Changed in launchpad:
assignee: nobody → Edwin Grubbs (edwin-grubbs)
Edwin Grubbs (edwin-grubbs) wrote :

Apparently, this problem in IE8 only rears its head when this is set.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

poy (poy) wrote :

indeed, as written above switching to compatibility mode solves it, but that is out of the question. also, it's not specific to the XHTML 1 Trans doctype but occurs also with XHTML 1 Strict and XHTML 1.1.

Changed in launchpad:
status: Confirmed → In Progress
Edwin Grubbs (edwin-grubbs) wrote :

Landed in rev8306 in db-devel.

Changed in launchpad:
status: In Progress → Fix Committed

Fixed released in Launchpad sinzui.

Changed in launchpad:
status: Fix Committed → Fix Released
Gérard Talbot (info-gtalbot) wrote :

Hello all,

I just wish to notify you all that I have reported the bug in my IE 8 browser bugs collection several days ago:

http://www.gtalbot.org/BrowserBugsSection/MSIE8Bugs/#bug228

visibility: inherit applied to command button fails in Internet Explorer 8
http://www.gtalbot.org/BrowserBugsSection/MSIE8Bugs/visibility-inherit-button.html

In the testcase, I kept the same identifiers from the original page and credits were given to Fredrik "DXter" Jonsson. It is an Internet Explorer 8 bug, occuring in web-standards compliant rendering mode.

<button> is rendered as an inline-block in IE 8, not as an inline like stated in bug 442805:
https://connect.microsoft.com/IE/feedback/ViewFeedback.aspx?FeedbackID=442805

so this means that this bug is different, distinct from bug 442805.

regards, Gérard

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers