Should support post-commit webhooks

Bug #342729 reported by Savvas Radevic on 2009-03-14
78
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
William Grant

Bug Description

It would be nice for Launchpad to support cia.vc commit updates server-side.
CIA provides IRC bots for channels and that could help the interaction and the vitality of a lot of projects and channels.

sourceforge.net and gna.org already have built-in support:
"You may already be using a hosting service, like SourceForge.net or Gna!, which provides built-in CIA.vc integration. Check with your hosting provider for details. You may need to ensure that CIA.vc and your hosting provider use the same project name."

Related branches

lp:~wgrant/launchpad/webhook-db
Colin Watson: Approve on 2015-07-10
lp:~wgrant/launchpad/webhook-model
Colin Watson: Approve on 2015-07-10
lp:~wgrant/launchpad/webhook-api
Colin Watson: Approve on 2015-07-10
lp:~wgrant/launchpad/webhook-jobrunner
Colin Watson: Approve on 2015-07-13
lp:~wgrant/launchpad/webhook-deletion
Colin Watson: Approve on 2015-07-21
lp:~wgrant/launchpad/webhook-retries
Colin Watson: Approve on 2015-07-29
lp:~wgrant/launchpad/webhook-retries-manual
Colin Watson: Approve on 2015-07-29
lp:~wgrant/launchpad/webhook-delivery-tweaks
Colin Watson: Approve on 2015-08-03
lp:~wgrant/launchpad/webhook-api-and-active
Colin Watson: Approve on 2015-08-04
lp:~wgrant/launchpad/webhook-browser
Colin Watson: Approve on 2015-08-05
lp:~wgrant/launchpad/webhook-event-types
Launchpad code reviewers: Pending requested 2015-08-10
lp:~wgrant/launchpad/webhook-trigger
Kit Randel: Approve on 2015-08-14
lp:~wgrant/launchpad/webhook-git-push
Kit Randel: Approve on 2015-08-14
lp:~wgrant/launchpad/webhook-proxy-errors
Colin Watson: Approve on 2015-08-24
lp:~wgrant/launchpad/webhook-deliveries-ui
Colin Watson: Approve on 2015-09-10
lp:~cjwatson/launchpad/db-bzr-webhooks
William Grant: Approve (db) on 2015-09-25
Stuart Bishop: Pending (db) requested 2015-09-24
lp:~cjwatson/launchpad/bzr-webhooks
William Grant: Approve (code) on 2015-09-29
lp:~cjwatson/launchpad/webhook-default-event-types
William Grant: Approve (code) on 2015-10-04
lp:~cjwatson/launchpad/webhook-payload-links
William Grant: Approve (code) on 2015-10-05
lp:~cjwatson/launchpad/add-webhook-secret
Colin Watson: Approve on 2015-10-26
description: updated

Just a "me too". CIA notification is great, it really helps people stay in touch with what's going on, and tends to stimulate code review (because the notices appear in IRC, where people can react to them in real-time and in concert).

See http://cia.vc/doc/ for an overview of how CIA works.

http://cia.vc/doc/clients/ has some instructions about Bazaar, but they seem a bit out-of-date. Jelmer or Robert may need to unify and/or update the plugins listed there.

Savvas Radevic (medigeek) wrote :

Confirming the bug then :)

There are more updated information on how to use the bzr-cia plugin: https://launchpad.net/bzr-cia
The bzr-cia plugin can be found in the package: cia-clients

Changed in launchpad:
status: New → Confirmed
William Grant (wgrant) on 2009-07-14
affects: launchpad → launchpad-code
Jonathan Lange (jml) on 2009-08-26
Changed in launchpad-code:
status: Confirmed → Triaged
importance: Undecided → Low
Dimitri John Ledkov (xnox) wrote :

http://cia.vc/blog/2009/03/google-revisited/

http://code.google.com/p/support/wiki/PostCommitWebHooks

Google code support has landed with elegant server side implementation. It's for http dunno how that will work since lp pushes using ssh....

Karl Fogel (kfogel) wrote :

How LP receives the code changes from users shouldn't affect how LP notifies CIA that the changes have happened. We can receive via SSH (or SFTP, or passenger pigeon, or whatever) and still notify CIA via HTTP or whatever is best.

Karl Fogel (kfogel) wrote :

By the way, we should consider using that Google Code system for commit hooks ourselves. It's a cute solution to the "users want to run arbitrary hooks, we don't want to run arbitrary code on our servers" problem.

Paul Hummer (rockstar) wrote :

Hey folks! If you're also interested in robotic landing, Tarmac currently does support CIA notifications when it merges branches for you. It's an okay workaround until Launchpad gets native support for it.

Tim Penhey (thumper) wrote :

I agree that it would be awesome to have post-commit web hooks. However the launchpad code team does not have the resources to put into this right now.

I'd personally be happy to mentor someone through this, but I don't have the time to do it myself.

Adi Roiban (adiroiban) wrote :

Whould it not be simpler to start by implementing a generic web hooks similar to what we have on github ?http://help.github.com/post-receive-hooks/

By doing so, project can implement their own LP to CIA hook gateways ... LP to ANY_OTHER_SYSTEM.

Is there a bug filed on LP to address this generic webhook feature? I would be happy to work on that.

On Tue, 06 Jul 2010 04:40:51 you wrote:
> Whould it not be simpler to start by implementing a generic web hooks
> similar to what we have on github ?http://help.github.com/post-receive-
> hooks/
>
> By doing so, project can implement their own LP to CIA hook gateways ...
> LP to ANY_OTHER_SYSTEM.
>
> Is there a bug filed on LP to address this generic webhook feature? I
> would be happy to work on that.

I think there is. I'll have to dig it up. I'd be happy to mentor the webhook
work. It is something I'd like to see but haven't had the personal bandwidth
to work on.

William Grant (wgrant) on 2013-08-13
summary: - [wishlist] Please add built-in support for cia.vc commit updates
+ Should support post-commit webhooks
William Grant (wgrant) on 2015-07-12
Changed in launchpad:
assignee: nobody → William Grant (wgrant)
status: Triaged → In Progress
Karl Fogel (kfogel) wrote :

\o/ wgrant

Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
William Grant (wgrant) on 2015-07-13
tags: added: qa-ok
removed: qa-needstesting
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Launchpad QA Bot (lpqabot) wrote :
Launchpad QA Bot (lpqabot) wrote :
William Grant (wgrant) on 2015-07-17
tags: added: qa-ok
removed: qa-needstesting
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
William Grant (wgrant) on 2015-07-24
tags: added: qa-ok
removed: qa-needstesting
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Launchpad QA Bot (lpqabot) wrote :
William Grant (wgrant) on 2015-07-30
tags: added: qa-ok
removed: qa-needstesting
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Launchpad QA Bot (lpqabot) wrote :
William Grant (wgrant) on 2015-08-05
tags: added: qa-ok
removed: qa-needstesting
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
William Grant (wgrant) on 2015-08-09
tags: added: qa-ok
removed: qa-needstesting
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Colin Watson (cjwatson) on 2015-08-17
tags: added: qa-ok
removed: qa-needstesting
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Colin Watson (cjwatson) wrote :
tags: added: qa-ok
removed: qa-needstesting
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Colin Watson (cjwatson) on 2015-08-28
tags: added: qa-ok
removed: qa-needstesting
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
William Grant (wgrant) on 2015-09-11
tags: added: qa-ok
removed: qa-needstesting
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Changed in launchpad:
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

2015-09-25 19:13:33,649 INFO 2209-66-1 applied just now in 0.3 seconds

tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson) on 2015-09-29
Changed in launchpad:
status: Fix Committed → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Colin Watson (cjwatson) on 2015-09-29
tags: added: qa-ok
removed: qa-needstesting
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Launchpad QA Bot (lpqabot) wrote :
Colin Watson (cjwatson) on 2015-10-05
tags: added: qa-ok
removed: qa-needstesting
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Colin Watson (cjwatson) on 2015-10-26
tags: added: qa-ok
removed: qa-needstesting
William Grant (wgrant) on 2016-03-15
Changed in launchpad:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers