Ubuntu packagers are not translation editors (assertion error)

Bug #334787 reported by Данило Шеган
2
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
Critical
Данило Шеган

Bug Description

After rollout, fix for bug #286359 has caused some issues. Namely, AssertionError is raised when importer doesn't have privileges to submit an is_imported translation, which makes rosetta-poimport script fail.

Since code is being called internally, we can override the check, but we'd need to be careful once we expose this through public API.

Changed in rosetta:
assignee: nobody → danilo
importance: Undecided → Critical
status: New → In Progress
description: updated
Revision history for this message
Данило Шеган (danilo) wrote :
Revision history for this message
Данило Шеган (danilo) wrote :

Fixed in db-devel 7766.

Changed in rosetta:
status: In Progress → Fix Committed
milestone: none → 2.2.2
Changed in rosetta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers