Make "this bug affects me too" bugs visible from user profile

Bug #323000 reported by Giles Weaver on 2009-01-30
344
This bug affects 71 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Martin Pool

Bug Description

It isn't currently possible for users to view the bugs that affect them.

It's possible to view subscribed bugs at https://bugs.launchpad.net/~username/+subscribedbugs
Ideally it would also be possible to view "bugs that affect me" from somewhere under the "bugs related to username" page (https://bugs.launchpad.net/~username).
The url could be https://bugs.launchpad.net/~username/+bugsthataffectme or similar.
This would allow users to track bugs that affect them without having to subscribe to them.

It would also be handy to have "bugs that affect me" status changes available as feeds or by email - useful if you aren't interested in the details of the bug, but just want to know when it is fixed.

This bug was related to this blueprint: https://blueprints.launchpad.net/malone/+spec/malone-me-too [the contents of that spec are on a closed-off wiki, but are not very interesting]

---

done: actual link is https://bugs.launchpad.net/~/+affectingbugs

Related branches

> The url could be https://bugs.launchpad.net/~username/+bugsthataffectme or similar.

Good idea and not terribly hard to do.

> It would also be handy to have "bugs that affect me" status changes
> available as feeds or by email - useful if you aren't interested in the
> details of the bug, but just want to know when it is fixed.

I like this idea. It would work well as an opt-in on your +edit page ("Send me emails about bugs that affect me" or some such).

 status triaged
 importance medium

Changed in malone:
importance: Undecided → Medium
status: New → Triaged
Karl Fogel (kfogel) wrote :

Note this should include bugs that affect the user via dupes. The branch committed for bug #505845 adds new properties for this: Bug.users_affected_with_dupes, Bug.users_affected_count_with_dupes, and Bug.users_unaffected.

Martin Pool (mbp) wrote :

Another case of this is that it would be nice to get a pre-canned search/count of bugs "affecting me" on a project homepage, under the high/incomplete/open etc list. That would help people come back to a bug they talked about before.

Martin Pool (mbp) on 2010-10-17
description: updated
ilon asolot (bal20aer) on 2011-02-19
Changed in launchpad:
assignee: nobody → ilon asolot (bal20aer)
status: Triaged → Confirmed
status: Confirmed → In Progress

@ilon if you want any help fixing this please just ask, here or on
irc. I would love to see it fixed.

Robert Collins (lifeless) wrote :

I'm updating this to reflect our updated bug triage - we don't use the medium category anymore: we pull bugs forward to high from low as our priorities change. This bug, while interesting, isn't in the current roadmap for active development.

Changed in launchpad:
importance: Medium → Low
yosergio64 (yosergio64) on 2011-02-26
Changed in launchpad:
status: In Progress → Fix Committed
status: Fix Committed → Confirmed
assignee: ilon asolot (bal20aer) → yosergio64 (yosergio64)
status: Confirmed → Invalid
assignee: yosergio64 (yosergio64) → nobody
Giles Weaver (gweaver) on 2011-02-26
Changed in launchpad:
status: Invalid → Confirmed
Curtis Hovey (sinzui) on 2011-02-26
Changed in launchpad:
status: Confirmed → Triaged
huwshimi (huwshimi) on 2011-04-14
tags: added: profile
Martin Pool (mbp) wrote :

split out bug 858618

Martin Pool (mbp) wrote :

screenshot of proposed fix

Changed in launchpad:
status: Triaged → In Progress
assignee: nobody → Martin Pool (mbp)
Giles Weaver (gweaver) wrote :

Looks almost exactly as I envisaged. Thanks for working on this.

Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Martin Pool (mbp) wrote :

qa at https://bugs.qastaging.launchpad.net/~/+affectingbugs

 * the url does exist
 * today it's consistently timing out for me on qas, but it was working on the weekend
  there is a link on it

Perhaps it's reasonable to hope it will be fast enough on lpnet, or that it can be improved separately?

https://bugs.qastaging.launchpad.net/~ is consistently timing out too.

description: updated
Martin Pool (mbp) on 2011-10-03
tags: added: qa-ok
removed: qa-needstesting
Rolf Leggewie (r0lf) wrote :

Thank you very much for this useful feature

I think it would be nice if the user were able to opt out of having this list world-readable

Martin Pool (mbp) on 2011-10-04
Changed in launchpad:
status: Fix Committed → Fix Released
Martin Pool (mbp) wrote :

now live, hooray!

@r0lf 'bug x affects y' is already public data (eg over the api) unless x is private.

Launchpad's general approach is that people's interactions on public projects are public: for instance I can find every bug you commented on either from your profile page or by a web search.

I can see how there is a bit of an issue that the ui currently looks like it only increments a counter, not records your person id, but fixes like this address that issue in a better way by actually making use of the affectsme data, and we can do more there.

If people don't want their interaction with public projects to be connected to their work or person life they are just better off interacting using a pseudonym, because there will always be leakage.

Giles Weaver (gweaver) wrote :

I'm getting the following error, perhaps I have too many bugs affecting me?!

https://bugs.launchpad.net/~gweaver/+affectingbugs

Timeout error

Sorry, something just went wrong in Launchpad.

We’ve recorded what happened, and we’ll fix it as soon as possible. Apologies for the inconvenience.

Trying again in a couple of minutes might work.

(Error ID: OOPS-2103CE39)

I, too, am getting the timeout. After a few refreshes it finally came through, though.

Martin Pool (mbp) wrote :

The timeouts are bug 866100 or similar.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers