Launchpad mail notifications may use References header referencing the same email : confuses Thunderbird threading in < 3.0

Bug #320034 reported by Emilio Pozuelo Monfort on 2009-01-22
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Colin Watson
Mozilla Thunderbird
Fix Released
Medium
thunderbird (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: thunderbird

Thunderbird threading doesn't work well for Launchpad bugmail. All the bugmail for one bug is in a thread, except the initial mail, which is sepparated.

Looks like the issue may be the initial mail having a References header referencing itself, e.g.:

Date: Wed, 21 Jan 2009 23:35:44 -0000
From: muadnem <hidden>
To: <email address hidden>
Reply-To: Bug 319820 <email address hidden>
Sender: <email address hidden>
[...]
References: <email address hidden>
Message-Id: <email address hidden>
Subject: [Bug 319820] [NEW] ubuntu 8.10 - gstreamer - totem - internal data
 stream error

Related branches

lp:~cjwatson/launchpad/bug-self-references
William Grant: Approve (code) on 2015-07-07
Alexander Sack (asac) wrote :

would be good to have a mbox file with just one launchpad thread, so its easy to test/reproduce for folks that have no LP bugmail subscriptions.

Changed in thunderbird:
importance: Undecided → Low
status: New → Triaged
Alexander Sack (asac) wrote :

malone should not send a self-References:, however tbird could deal more gracefully with those situations too.

... pasted first tbird attempt to not deal with self-References: at all: http://paste.ubuntu.com/108227/ ... should be dealt with upstream.

Alexander Sack (asac) wrote :

confirmed that the patch works. Recreating mailbox indexes for already downloaded mails is required though ... aka rm *.msf.

From ubuntu bug (https://launchpad.net/bugs/320034):

Thunderbird threading doesn't work well for Launchpad bugmail. All the bugmail for one bug is in a thread, except the initial mail, which is sepparated.

Looks like the issue may be the initial mail having a References header referencing itself, e.g.:

Date: Wed, 21 Jan 2009 23:35:44 -0000
From: muadnem <hidden>
To: <email address hidden>
Reply-To: Bug 319820 <email address hidden>
Sender: <email address hidden>
[...]
References: <email address hidden>
Message-Id: <email address hidden>
Subject: [Bug 319820] [NEW] ubuntu 8.10 - gstreamer - totem - internal data
 stream error

Created attachment 358181
ignore self-References

fix by ignoring references identical to current message-id.

The other place to fix this would probably in the threading algorithm itself. I can take a look at that if we don't want to ignore self-references in msg headers completely

forwarded bug and patch to https://bugzilla.mozilla.org/show_bug.cgi?id=474790 ... lets see if they concur with this approach or if we need to fix the thread construction logic.

Changed in thunderbird:
status: Unknown → Confirmed
Björn Tillenius (bjornt) wrote :

Let's see if we can get this fixed in Launchpad this cycle, should be an easy fix.

Changed in malone:
milestone: none → 2.2.1
status: New → Triaged

(In reply to comment #0)
> Thunderbird threading doesn't work well for Launchpad bugmail. All the bugmail
> for one bug is in a thread, except the initial mail, which is sepparated.
>
> Looks like the issue may be the initial mail having a References header
> referencing itself, e.g.:

RFC 822 states "4.6.3. REFERENCES
The contents of this field identify other correspondence which this message references. Note that if message identifiers are used, they must use the msg-id specification format." (http://www.w3.org/Protocols/rfc822/#z33).

Personally, seems like Launchpad is doing something wrong here by referencing itself in the first mail. Can't this be fixed at the Launchpad level? If Launchpad was open source, I'd even submit a patch.

Changed in thunderbird:
status: Confirmed → In Progress

(In reply to comment #2)
> (In reply to comment #0)
> > Thunderbird threading doesn't work well for Launchpad bugmail. All the bugmail
> > for one bug is in a thread, except the initial mail, which is sepparated.
> >
> > Looks like the issue may be the initial mail having a References header
> > referencing itself, e.g.:
>
> RFC 822 states "4.6.3. REFERENCES
> The contents of this field identify other correspondence which this message
> references. Note that if message identifiers are used, they must use the msg-id
> specification format." (http://www.w3.org/Protocols/rfc822/#z33).
>
> Personally, seems like Launchpad is doing something wrong here by referencing
> itself in the first mail. Can't this be fixed at the Launchpad level? If
> Launchpad was open source, I'd even submit a patch.

... LP will be opened on 21st Jul 09!

Anyway, even though we can fix this on launchpad side too (and yes, we should) all other mailers i have tested get this threading right; just tbird is confused by a References: to itself.

Changed in malone:
importance: Undecided → Medium
milestone: 2.2.1 → none

Björn Tillenius escribió:
> Let's see if we can get this fixed in Launchpad this cycle, should be an
> easy fix.

Ping? :)

I need to patch thunderbird myself to workaround this bug...

Comment on attachment 358181
ignore self-References

bienvenu is a better reviewer than me for this, sorry for not shifting it over earlier.

Is this still broken in TB 3.0 b4?

Comment on attachment 358181
ignore self-References

Thx for the patch - I like it and I'm going to clean it up a little and land it.

thx. in case you give credits in commit use <email address hidden> ;) ...

thx for the fix, Alexander, credit noted and change pushed.

(In reply to comment #8)
> thx for the fix, Alexander, credit noted and change pushed.

http://hg.mozilla.org/comm-central/rev/70552ed90c20

Changed in thunderbird:
status: In Progress → Fix Released
Micah Gersten (micahg) on 2009-12-14
Changed in thunderbird:
milestone: none → 3.0
Download full text (6.7 KiB)

This bug was fixed in the package thunderbird - 3.0+nobinonly-0ubuntu1

---------------
thunderbird (3.0+nobinonly-0ubuntu1) lucid; urgency=low

  * New Upstream Release 3.0 (THUNDERBIRD_3_0_RELEASE)
    - LP: #50902 - Thunderbird displays useless dialog
    - LP: #52667 - Thunderbird doesn't support RFC-2369
    - LP: #49033 - Doesn't recognize upper case extension (.JPG)
    - LP: #56465 - Per folder column widths
    - LP: #68456 - CTRL-Shift-K bound to 2 functions
    - LP: #79337 - Typo in Server Information for Add Account Wizard
    - LP: #1084 - No scroll on full headers list
    - LP: #62071 - Middle click on scrollbar pastes instead of jumping
    - LP: #119358 - Weak default authentication mode
    - LP: #120672 - No option to empty junk folder with right click
    - LP: #96566 - movemail doesn't work with default privs
    - LP: #122529 - Non-Thunderbird IMAP folders not visible to Thunderbird
    - LP: #241276 - Not able to paste image into thunderbird compose window
    - LP: #244635 - scrollboxes scroll to offset 0 when resized
    - LP: #259387 - "Edit Message as New" broken for eml messages
    - LP: #120281 - Editing a message from the drafts folder leaves line breaks
    - LP: #115484 - Dialogue boxes too large for 1024x768 resolution
    - LP: #320034 - Mail with self referencing headers breaks threading
    - LP: #160794 - shortcuts different in windows and linux
    - LP: #280987 - thunderbird keeps asking a password when working off-line
    - LP: #369150 - Thunderbird splits email addresses with non-ascii characters
                    and a comma in From: field
    - LP: #135066 - Thunderbird doesn't use Ubuntu icon theme
    - LP: #297301 - after authentication error the password is forgotten
    - LP: #487541 - thunderbird-bin crashed with SIGSEGV (AFS filesystem)
    - LP: #485224 - Thunderbird saves double attachment file name endings on
                    FAT32 and NTFS
    - LP: #482496 - When using SCIM ANTHY, autosaving fails, and then get asked
                    about sending in UTF-8

  [ Fabien Tassin <email address hidden> ]
  * Add build-depends on autoconf2.13, autotolls-dev, mozilla-devscripts
    libglib2.0-dev (>= 2.12), libstartup-notification0-dev, libbz2-dev,
    libpixman-1-dev, libdbus-1-dev (>= 1.0.0), libdbus-glib-1-dev (>= 0.60),
    libhal-dev (>= 0.5.8), libasound2-dev, libreadline5-dev | libreadline-dev,
    libkrb5-dev
  * Update build-depends minimums for libx11-dev (>= 2:1.0),
    libgtk2.0-dev (>= 2.12), zlib1g-dev (>= 1:1.2.3), libpng12-dev (>= 1.2.0),
    libjpeg62-dev (>= 6b), libcairo2-dev (>= 0.5.8), libgnome2-dev (>= 2.16),
    libgnomevfs2-dev (>= 1:2.16), libgnomeui-dev (>= 2.16),
    libnss3-dev (>= 3.12.0~1.9b3)
  * Bump standards version to 3.8.0
  * Replace ${Source-Version} by ${binary:Version} in control file
    - update debian/control
  * Bump requirement for system nspr to >= 4.8 since Mozilla bug 492464 landed
  * Bump requirement for system nss to >= 3.12.3 since Mozilla bug 485052 landed
  * Use in-source hunspell when hunspell 1.2 is not available
  * Add conditionnal support for --with-libxul-sdk controlled by
    $(USE_SYSTEM_XUL)
    - update debian/rules
  * Add p...

Read more...

Changed in thunderbird (Ubuntu):
status: Triaged → Fix Released
Changed in thunderbird:
importance: Unknown → Medium
Changed in launchpad:
importance: Medium → High
tags: added: bugs email
removed: lp-bugs pet-bug
summary: - Launchpad bugmail having the References header referencing itself
- confuses Thunderbird threading
+ Launchpad mail notifications may use References header referencing the
+ same email : confuses Thunderbird threading in < 3.0
tags: added: notifications
Micah Gersten (micahg) wrote :

Thunderbird 2 isn't officially supported in Ubuntu or upstream anymore. I would suggest this be closed won't fix or marked Low if this is the only E-Mail client affected by this.

Colin Watson (cjwatson) on 2015-07-06
Changed in launchpad:
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Colin Watson (cjwatson) on 2015-07-07
tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson) on 2015-07-07
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.